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About the TDSHT3 HDMI Compliance Test Software TDSHT3 HDMI Compliance Test Software

TDSHT3 HDMI Compliance Test Software

NOTE. You will be provided with two TDSHT3 applications, one supporting CTS 1.2a specification
displayed as TDSHT3 and the other supporting CTS 1.3b1 specification displayed as TDSHT3v1.3. Both
of these applications can be loaded onto the oscilloscope but you can run only one application at a time.

The TDSHT3 HDMI Compliance Test Software is a High Definition Multimedia Interface (HDMI)
compliance test solution. This software helps the test, validation, and design engineers perform both
HDMI physical layer validation and compliance testing. The TDSHT3 HDMI Compliance Test Software
provides credible test results in conformance with the HDMI standards and test specifications.
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About the TDSHT3 HDMI Compliance Test Software TDSHT3 HDMI Compliance Test Software

The TDSHT3 HDMI Compliance Test Software offers automated tests for:

Source
Differential Tests

Eye Diagram (Test ID 7-10)

Duty Cycle (Test ID 7-8)

Rise Time (Test ID 7-4)

Fall Time (Test ID 7-4)

Clock Jitter (Test ID 7-9)

Inter-Pair Skew (Test ID 7-6)

Single-Ended Tests

Intra-Pair Skew (Test ID 7-7)

Low Amplitude + (Test ID 7-2)

Low Amplitude - (Test ID 7-2)

Sink
Differential Tests

Min/ Max-Diff Swing Tolerance (Test ID 8-5),

Jitter Tolerance (Test ID 8-7)

Single-Ended Tests

Intra-Pair Skew (Test ID 8-6)

Cable
Differential Tests

Eye Diagram (Test ID 5-3)

The software offers automatic “one-button” testing that ensures faster validation with higher reliability and
it supports only single-link HDMI device resolutions.

See Also
Compatibility

Requirements and Restrictions

Recommended Accessories
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Introduction How to Use Online Help

How to Use Online Help
The online help system serves as a reference on how to use the TDSHT3 HDMI Compliance Test Software.

Contents: The Contents tab displays books and pages that represent the categories of information in
the online help system.

Index: The Index tab displays a multi-level list of keywords and keyword phrases. These terms are
associated with topics in the help system and direct you to specific topics.

Search: The Search tab enables you to search for keywords in the help system and to locate topics
containing those words. When the search is completed, a list of topics is displayed so that you can select a
specific topic to view.

To print a Help topic: Right-click the topic you want to print, and then click Print.

Conventions
Online help uses the following conventions:

When steps require a sequence of selections by using the software interface, the “>” delimiter marks
each transition between a menu and an option, for example, File > Minimize.

Device under Test (DUT) refers to the HDMI Source, Sink, or Cable being tested.

Two or more adjacent hyperlinks are separated by “|.”

The software uses the following convention:

Three dots “...” next to any command means that the command opens a dialog box, which requires input.

Feedback
Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on the TDSHT3 HDMI Compliance Test Software.

Direct your feedback via e-mail to HDMIFeedback@tek.com or FAX at (503) 627-5695 and include the
following information. Please be as specific as possible.

General information
Instrument model number and hardware options, if any

Probes used
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Your name, company, mailing address, phone number, FAX number, e-mail id

Please indicate if you would like to be contacted by Tektronix about your suggestions or comments

Program specific information
Software version number

Description of the problem such that technical support can duplicate the problem

The instrument setup file of the oscilloscope and the application are also required to identify the problem

If possible, save the waveform on which you are performing the test as a .wfm file

NOTE. To know the software version number, click Help > About in the software.

Once you have gathered this information, you can contact technical support by e-mail. When you use
e-mail, be sure to type in the subject line “TDSHT3 HDMI Compliance Test Software Problem,” and then
attach the .wfm files.
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Getting Started Compatibility

Compatibility
For information on oscilloscope compatibility, refer to the Optional Applications Software on
Windows-Based Oscilloscopes Installation Manual, Tektronix Part Number, 071-1888-XX. The manual is
available as a PDF file.

Recommended Accessories
The following probes and test fixtures are recommended for TDSHT3 HDMI Software.

Supported Probes
P7313SMA – 13 GHz recommended differential probe

The following probes can be used with old fixtures except for P7350SMA:

P7350 – 5 GHz differential probe

P7350SMA – 5 GHz differential probe

P7330 – 4 GHz differential probe

P6330 – 4 GHz differential probe

P7380 – 8 GHz differential probe

P7240 – 4 GHz single-ended probe

Supported Test Fixtures
ET-HDMI-TPA-R , available from Efficere Technologies

ET-HDMI-TPA-P , available from Efficere Technologies

The following test fixtures can only work for limited HDMI resolutions.

HDMI-TPA-P-DI

HDMI-TPA-P-SE

HDMI-TPA-P-TDR

HDMI-TPA-R-DI

HDMI-TPA-R-SE

HDMI-TPA-R-TDR
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The fixtures are available under the Tektronix ordering system with the following part numbers:

ET-HDMI-TPA-S – HDMI Type A fixture set for Tx, Rx, and Cable testing. It includes the following:

One HDMI-TPA-P plug board with SMA cables

One HDMI-TPA-R receptacle board with SMA cables

One HDMI-TPA-C calibration board with SMA cables

One HDMI-TPA-E, EEPROM board, 29 SMA to GPPO cables two inches long

ET-HDMI-TPA-STX – HDMI Type A fixture set for Tx testing only. It includes the following:

One HDMI-TPA-P plug board with 10 GPPO to SMA cables two inches long

One HDMI-TPA-E, EEPROM board

ET-HDMIC-TPA-S – HDMI Type C fixture set for Tx, Rx, and Cable testing. It includes the following:

One HDMI-TPA-P plug board with SMA cables

One HDMI-TPA-R receptacle board with SMA cables

One HDMI-TPA-C calibration board with SMA cables

One HDMI-TPA-E, EEPROM board, 29 SMA to GPPO cables two inches long

ET-HDMIC-TPA-STX - HDMI Type C fixture set for Tx testing only. It includes the following:

One HDMI-TPA-P plug board with 10 GPPO to SMA cables two inches long

One HDMI-TPA-E, EEPROM board

Connectivity
GPIB (recommended for DPO/DSA70000 series oscilloscope)

USB-GPIB (HS)

E-Net Switch

Requirements and Restrictions
TekVisa must be installed on the oscilloscope. If you do not have TekVISA, you can download it
from www.tektronix.com/software.

If the signal is not connected and the noise level is less than 50 mV, then the software detects and
displays a message such as “Improper Waveform.”

NOTE. Do not change the oscilloscope settings when the test runs. If you change the settings when the test
runs, the software may give abnormal test results.
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For Better and Reliable Results
Before you run any test, calibrate the probes and oscilloscope for Signal Path Compensation. On the
oscilloscope menu bar, click Utilities > Instrument Calibration and then click Calibrate to calibrate
the oscilloscope.

If the signal is not connected and the noise level is less than 50 mV, then the software detects and gives
a message such as “Invalid Signal.”

Default Settings

Parameter Selection Default setting
Flow Controls Select
Device Type Tab Source (Differential Tests)
Source Test Eye Diagram
Sink Test Min/Max-Diff Swing Tolerance

(Differential)

Select

Cable Test Eye Diagram
Clock Input Ch1
Data0 Input Ch2
Data1 Input Ch3

Source Configuration

Data2 Input Ch4
CRU Clock PLL
Others Ref Level Units Percentage

DTG file path C:\TekApplications\TD-

SHT3v1-3\ComplianceTest-

Patterns\ PC\1920X1080i

50Hz 8 Bit Gray RGB PC

V3-3.dtg

Clock output from DTG A1
Data0 output from DTG B1
Data1 output from DTG B2

Sink Configuration

Data2 output from DTG C1
Signal Sources Tab DTG

AWG Unavailable
AFG Unavailable

Control Type GPIB
Board Type GPIB0
GPIB Address (Primary) 1

Signal Sources

GPIB Address (Secondary) 0
View Waveform Clock/Data Waveforms

TDSHT3 HDMI Compliance Test Software Online Help 7



Getting Started Default Settings

Parameter Selection Default setting
View Jitter Plot Unavailable
View Eye Plot Unavailable
Data Lane Unavailable

Result Summary

Test Point Unavailable
View Jitter Plot Unavailable
View Eye Plot Unavailable

Result Details

Result Statistics Unavailable
From Input Setup - Input - Ch1
From Input Setup - Hysteresis - 10%
From Input Setup - Ref Level - 50%
To Input Setup - Input - Ch2
To Input Setup - Hysteresis - 10%
To Input Setup - Ref Level - 50%
Slope - Rise

External

Slope - # of Slopes - 1
From Input Setup - Input - Ch1
To Input Setup - Input - Ch2

Deskew

Internal

Slope - Rise
Device Details HDMI Device
Resolution 1920*1080i
Refresh Rate 60Hz
Report File Disabled
Auto Increment Selected
Save As Disabled

Report Configuration pane

Clear Report Enabled
xxx
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How to Start the Software
When you start the software, a warning message box may appear.

This happens due to the following reasons:

1. Four channel feature is supported only on DPO/DSA70000 series oscilloscopes having bandwidth
greater than or equal to 8 GHz. For TDS series oscilloscopes, only two channels are available and
the other two channels are displayed as Not Conn.

2. Oscilloscope bandwidth is less than 8 GHz. For higher resolution HDMI signals, you need at least a
8 GHz oscilloscope. Your oscilloscope bandwidth is less than 8 GHz.

3. Maximum available record length for two channels is less than 16 M. For HDMI compliance
testing, you need at least 16 M record length in two channels. This 16 M record length is installed in
the following oscilloscopes:

Option 4M and above in TDS series oscilloscopes

Option 2XL and above in DPO series oscilloscopes

If these options are not available (installed) in the oscilloscope, the software will run the Eye diagram
and Jitter measurements with the maximum available record length.
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Depending on the type of oscilloscope that you have, you can start the software in different ways.

1. For supported B-series oscilloscopes, select App > HDMI Compliance Test Software(1.3).

2. For TDS7000-series oscilloscopes, select File > Run Application >HDMI Compliance Test
Software(1.3).

3. For DPO70000-series and DSA70000-series oscilloscopes, select Analyze > HDMI Compliance Test
Software(1.3).

10 TDSHT3 HDMI Compliance Test Software Online Help



Getting Started How to Start the Software

4. A splash screen indicates that the software loading is in progress.

5. The oscilloscope display resizes to fit in the upper part of the screen. The lower part of the oscilloscope
screen displays the TDSHT3 HDMI Compliance Test Software.
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6. The software is automatically set to its default settings.

7. If you gain access to the oscilloscope functions, then the oscilloscope display appears full screen and
the TDSHT3 HDMI Compliance Test Software recedes to the background.

How to Minimize and Maximize the Software
The software appears even when you minimize the oscilloscope display.

To minimize the software, click File > Minimize. The TDSHT3 HDMI Compliance Test Software
window minimizes to the Windows taskbar. The upper part of the screen has the oscilloscope display
and the lower part of the screen has the desktop.

To restore the minimized window to its previous size, click its taskbar button.

To hide the window, click Hide on the top-right of the software window.

NOTE. If you click Hide, the TDSHT3 HDMI Compliance Test Software window goes to the background
and the oscilloscope fills the display.

How to Return to the Software
When you gain access to the oscilloscope functions, the oscilloscope fills the display. You can gain access
to the oscilloscope functions in the following ways:

Choose either the menu bar or the toolbar mode on the oscilloscope, and then gain access to the menus.

Click App > Restore Application for B-series, click Analyze > Restore Application for

DPO70000/DSA70000 series, or click APP on the top right of the TDS7000 series oscilloscope
display to return to the software.

See Also
Exit

How to Exit the Software
To quit the software:

On the menu bar, click File > Exit.

The Exit dialog box appears.
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Click either Yes, No, or Cancel. Yes is selected by default. When the software runs, it automatically
changes some oscilloscope settings. When you quit the software, you can choose whether to retain
these settings or restore the previous settings.

NOTE. Using other methods to quit the software may result in an abnormal termination of the software.

Software Folders and File Names
The TDSHT3 HDMI Compliance Test Software uses file name extensions to identify the file type. The
following table lists the default folder names and their purpose:

Folder Purpose
C:\TekApplications\TDSHT3v1-3 This is the software data folder.
C:\TekApplications\TDSHT3v1-3\Images This folder stores all the images.
C:\TekApplications\TDSHT3v1-3\Data This folder stores all the software data.
C:\TekApplications\TDSHT3v1-3\setup This folder stores all the save and recall files.
C:\TekApplications\TDSHT3v1-3\Demo

Tools
This folder stores the demo waveforms.

C:\TekApplications\TDSHT3v1-3\Reports This folder stores the reports.
xxx

Shortcut Keys
Menu Shortcut key
File Alt+F
Tests Alt+T
Results Alt+R
Utilities Alt+U
Help Alt+H
File > Recall Compliance Default Alt+F+D
File > Recall Alt+F+R
File > Recall > First Recent Alt+F+E+1
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Menu Shortcut key
File > Recall > Second Recent Alt+F+E+2
File > Recall > Third Recent Alt+F+E+3
File > Recall > Fourth Recent Alt+F+E+4
File > Save Alt+F+S
File > Recall Recent Alt+F+E
File > Preferences Alt+F+P
File > Preferences > Position Eye Mask in Center Alt+F+P+M
File > Preferences > Acquisition Alert Message Alt+F+P+A
File > Preferences > Jitter Tolerance (No calibration) Alt+F+P+J
File > Preferences > Single Ended (With 50ohm term) Alt+F+P+S
File > Preferences > Set the probe control to internal 3.3 V Alt+F+P+C
File > Minimize Alt+F+M
File > Exit Alt+F+X
Tests > Select Alt+T+S
Tests > Select > Source Alt+T+S+S
Tests > Select > Sink Alt+T+S+K
Tests > Select > Cable Alt+T+S+C
Tests > Configure Alt+T+C
Tests > Connect Alt+T+N
Tests > View Waveform Alt+T+V
Results > Summary Alt+R+S
Results > Details Alt+R+D
Utilities > Deskew Alt+U+D
Utilities > DTG Pattern List Alt+U+P
Help > Help Topics Alt+H+T
Help > About HDMI Alt+H+A
xxx
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TDSHT3 HDMI Compliance Test Software Error Codes
The following table lists the error codes, their descriptions, and the possible solutions:

Error code Error message Description Possible solution
101 Input is “Not Conn.” Both the selected sources

are not connected.
Select valid channels
(Ch1-Ch2, Ref1-Ref2)
for at least clock/data
source/data source
(differential tests) or for
input1/input2 (single-ended
tests).

102 Conflict in the selection of
inputs.

The sources that are
selected for the two inputs
are the same. The inputs
clock source and data
source for differential tests,
input 1 and input 2 for
single-ended tests.

Select different channel
sources for input 1 and
input 2 for single-ended
tests and different channel
sources for clock source
and data source for
differential tests.

103 The combination of Ref
and Live input signals is not
valid.

The software supports
both Ref or both Live
combinations of channels.

Select both ref channels or
both live channels for clock
and data source.

104 Ref Wfm is not valid. The software cannot switch
on ref waveforms. Ref
waveforms could be empty.

Recall the required ref
waveform from the
appropriate file on the
oscilloscope.

105 Conflict in GPIB Selection. There is a conflict in the
selection of GPIB address.
One or more addresses are
repeated.

Ensure that no two GPIB
addresses are identical.

106 Conflict in the selection of
input types.

There is a conflict in the
selection of the inputs.
One or more inputs are
repeated.

Ensure that the
combination of the selected
inputs are unique.

107 Four channel feature
is supported only on
DPO/DSA70000 series
oscilloscopes having
bandwidth greater than or
equal to 8 GHz.

The four channel feature
is not supported in the
oscilloscope.

Reduce the number of
channels to two and
proceed.

110 Unable to acquire
waveform.

The oscilloscope is not able
to acquire the signal and
trigger.

Ensure that the software
configurations are proper.
Check the probes and test
fixture connections. If the
test uses serial trigger,
ensure that the CTL pattern
is present on the waveform.
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Error code Error message Description Possible solution
111 Not enough acquisitions to

perform the test.
The software expects to
acquire a minimum number
of acquisitions that are
configured.

Ensure that the software
configurations are proper.
Check the probes and test
fixture connections.

113 Error in importing the Wfm. The software could not
import the waveform from
acquisition. This happens
when there is no valid
waveform in the acquisition
memory.

Check the probes and test
fixture connections. Run
the test again.

114 Improper Wfm. Signal is not probed at the
proper test points.

Refer to the connections
diagram and probe the
proper signal.

115 Ref Wfms have different
Record Lengths/Sample
Rates.

The ref waveforms have
different sample rates
and/or record lengths.

Use waveforms that are
acquired simultaneously for
ref waveforms.

121 Ref Levels entered are
outside the range of the
Wfm.

Unable to locate the edges
on the waveform at the
transition because the
levels configured do not fall
within the transition of the
waveform.

Enter the Ref Level voltage
value where the transition
occurs on the waveform.
Enter 50 percent of the
level of the peak-to-peak
transition level for mid-ref
levels, 80 percent of the
peak-to-peak for high-ref
levels, and 20 percent of
the peak-to-peak for low ref
levels.

122 ((Hysteresis Level/2) + Ref
Level) cannot be greater
than 100 percent.

((Hysteresis Level/2) + Ref
Level) has to be within 100
percent for edge finding.

Set both the ref and
(Hysteresis Level/2) to be
less than 100 percent.

123 High Level is less than or
equal to Low Level.

The configured high level
value is less than the low
level value.

Configure the high level
to be greater than the low
level.

131 Error in calculating Tbit. Not a valid clock waveform. Supply a valid clock
waveform and run the test
again.

132 Clock input is required to
calculate Tbit.

The Tbit value has to be
calculated before you run
a test that uses only data
source(s ).

1. Select and run a test
that uses clock source
for Tbit value.

2. Click Connect, select
clock source, and then
click Re-calculate Tbit
before you run the test.

152 Select any test to continue. Configure, Connect, View
Waveform, and Run Test
need at least one test to be
selected.

Select at least one test
before you click either
Configure, Connect, View
Waveform, or Run Test.

16 TDSHT3 HDMI Compliance Test Software Online Help



Getting Started TDSHT3 HDMI Compliance Test Software Error Codes

Error code Error message Description Possible solution
161 Unable to recover clock. Improper waveform or the

software components are
missing.

Supply the proper
waveform. Reinstall the
software.

171 Unable to find edges. The waveform may be
noisy or the hysteresis level
may be low.

Check the probes and
test fixture connections.
Increase the hysteresis
band level.

172 Not enough edges. Number of edges found on
the waveform is less than
the minimum number of
edges that is required for
the test.

Decrease the horizontal
scale to have more
complete cycles of the
waveform. Adjust the
hysteresis level of the
signal to find the edge at
the required level.

173 Unable to calculate skew. Could not find the mid of
the waveform.

Check the probes and test
fixture connections.

174 CTL pattern not found. The CTL pattern
0010101011 was not
found on the waveform.

Ensure that the appropriate
pattern is present on
the source waveform.
Change the polarity of the
waveform.

175 Option ST is not installed
on the oscilloscope.

Option ST is not available
on the oscilloscope.

Install Option ST.

178 Unable to calculate Vswing. Signal is not probed at the
proper test points.

Follow the instructions in
the setup diagram and
probe the proper signal.

181 Check the DTG connection. DTG connection has failed.
This could happen if:

The DTG is not
switched on.

There is a mismatch
in the GPIB-ENET
configuration, software
GPIB configuration, or
DTG remote control
configuration.

The GPIB cable is not
connected properly.

Switch on the DTG
and wait for the DTG
software to load.

Check GPIB
connections.

Ensure that the
primary and secondary
addresses of DTG
in the remote control
match the GPIB-ENET
configuration of the
oscilloscope.

Ensure that
the GPIB-ENET
configuration on your
oscilloscope matches
the signal sources
configuration in the
software.
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Error code Error message Description Possible solution
182 File not found in the DTG. The configured file is not

found in the DTG.
Ensure that the specified
file in the software is
present in the DTG. Specify
a file name that is present
in the DTG.

183 Invalid logical channel. The logical channel is
invalid.

Provide a proper logical
channel.

184 Conflict in selection of
outputs from the DTG.

The same physical channel
(A1, A2, B1, B2, C1, C2,
D1, D2) is selected for any
two logical channels (Clock,
Data0, Data1, Data2).

Select different physical
channels (A1, A2, B1, B2,
C1, C2, D1, D2) for a given
logical channel (Clock,
Data0, Data1, Data2).

191 Check the AWG
connection.

AWG connection has failed.
This could happen if:

The AWG is not
switched on.

There is a mismatch
in the GPIB-ENET
configuration,
application GPIB
configuration, and
AWG remote control
configuration.

The GPIB cable is not
connected properly.

Switch on the AWG
and wait for the AWG
software to load. Check
GPIB connections.
Ensure that the primary
address of AWG in the
Utility > Network >
Address matches with the
GPIB-ENET configuration
of the oscilloscope. Ensure
that the GPIB-ENET
configuration on your
oscilloscope matches
the signal sources
configuration in the
software.

192 File not found in the AWG. File is not present in the
AWG.

Ensure that the required
file is present in the AWG.
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Error code Error message Description Possible solution
193 Check the Signal Sources

connection.
Signal sources connection
has failed. It may be due
to DTG or AWG connection
failure. DTG connection
has failed. This could
happen if:

The DTG is not
switched on.

There is a mismatch
in the GPIB-ENET
configuration, software
GPIB configuration,
and DTG remote
control configuration.

If the GPIB cable is not
connected properly.

AWG connection has failed.
This could happen if:

The AWG is not
switched on.

There is a mismatch
in the GPIB-ENET
configuration, software
GPIB configuration,
and AWG remote
control configuration.

If the GPIB cable is not
connected properly.

Primary addresses of
DTG and AWG are
same.

For DTG connection failure:

Switch on the DTG
and wait for the DTG
software to load.

Check the GPIB
connections.

Ensure that the primary
address of DTG in the
remote control matches
the GPIB-ENET
configuration of the
oscilloscope.

Ensure that
the GPIB-ENET
configuration on your
oscilloscope matches
the signal sources
configuration in the
software.

For AWG connection
failure:

Switch on the AWG
and wait for the AWG
software to load.

Check the GPIB
connections.

Ensure that the primary
address of AWG in
the Utility > Network
> Address matches
with the GPIB-ENET
configuration of the
oscilloscope.

Ensure that
the GPIB-ENET
configuration on your
oscilloscope and signal
sources configuration
in the software match.

Select distinct primary
addresses for DTG and
AWG.

194 Jitter value is unavailable. Signal is not probed at the
proper test points.

Follow the instructions in
the setup diagram and
probe the proper signal.
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Error code Error message Description Possible solution
196 Invalid DUT frequency. The frequency of the DUT

configured in Configure >
Setup > DUT Freq (MHz)
does not match with the
frequency of the signal
generated from the DTG.

Load the required pattern
on the DTG and check
the frequency of the
signal. Ensure that the
same frequency has been
configured in the DUT Freq
(MHz).

201 Edges on the Wfm are
lesser than the configured
number of edges.

Deskew number of edges
set by the user to perform
the deskew is not available
on the waveform.

Ensure that the edges
in the waveform and the
display in the numeric input
are the same. Adjust the
horizontal scale to increase
the number of transitions
that is required to adjust
the deskew.

202 Calculated skew is greater
than the oscilloscope skew
range.

The calculated skew
value is greater than the
oscilloscope deskew range.

The deskew will be done
to the maximum deskew
value that is applicable to
the oscilloscope.

203 Cycle has less than
20 sample points.

Insufficient number of
samples in a complete
cycle. The number of data
points in the identified cycle
is less than 20.

Increase the sampling rate.

211 Select the test point(s) to
continue.

No test points are selected. Select any one or both
of the test points in cable
configuration.

221 Mask cannot be moved
beyond this position.

Upper and lower masks
have exceeded their
boundary values. The
mask co-ordinates are
beyond the plottable area.

Change the Mask
Movement mode from
Coarse to Fine. After
changing to Fine, you
will be able to move
a bit further. If you
are already in Fine
mode, and this message
appears, then you are in
the maximum/minimum
possible position.

222 Unable to calculate mask
margins.

An error occurred while
calculating the mask
margins.

The signal may be wrong
(noise, invalid pattern).
Connection to the probe tip
may be loose. Recheck the
connection and run the test
again.
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Error code Error message Description Possible solution
251 Check the AFG connection. Connection to AFG has

failed. This could happen if:

The AFG is not
switched on.

There is a mismatch
in the GPIB-ENET
configuration, software
GPIB configuration,
and AFG remote
control configuration.

If the GPIB cable is not
connected properly.

Primary addresses of
the signal sources are
same.

Perform the following:

Switch on the AFG
and wait for the AFG
software to load.

Check the GPIB
connections.

Ensure that the primary
address of AFG in the
remote control matches
the GPIB-ENET
configuration of the
oscilloscope.

Ensure that
the GPIB-ENET
configuration on your
oscilloscope matches
the signal sources
configuration in the
software.

Select distinct primary
addresses for the
signal sources.

252 Four DTGM30 modules
are required to run this
measurement.

An error occurs when
any of the four connected
modules is not DTGM30.

Connect four
DTGM30 modules to
the DTG and run the test.

401 AWG pattern directory not
found.

The required directory is
not present in the AWG.

Reinstall the AWG pattern
files.

402 Unable to turn on the
AWG output due to invalid
external input clock.
Connect the external clock
and turn ON the outputs to
proceed.

Invalid/missing external
clock.

Ensure that the correct
external clock is connected
before turning ON the
outputs.

xxx
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TDSHT3 HDMI Compliance Test Software Window
The software window includes a menu bar, selection pane, test selection pane, execution pane, and status
bar. The client pane changes between the selection pane, configuration pane, connection pane, and view
waveform pane depending on what you have selected in the selection pane. After you run the test, the
client pane automatically changes to the result pane.

TDSHT3 HDMI Compliance Test Software Interface Controls
The software uses a Windows interface.

NOTE. The oscilloscope software shrinks to fit in the top part of the display when the TDSHT3 HDMI
Compliance Test Software runs.

The software interface uses the following controls:

Control Description
Menu bar The Menu bar provides access to the software menus. It is

located at the top of the software window.
Area/Tab An Area/Tab control encloses visual frame with a set of

related options.
Option button An Option button allows you to select either a command

or a task.
Drop-down list box A Drop-down list box lists items from which you can select

one item.
Field A Field is a box where you can enter text or values.
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Control Description
Check boxes You can select or clear check boxes that you use to set

preferences.
Scroll bar A Scroll bar is a vertical or horizontal bar at the side or

bottom of a display area that is used to move around that
area.

Browse Browse refers to the window where you can browse through
a list of folders and files.

Command button A Command button refers to the usually rectangular button
that carries out a command and may initiate immediate
action.

Numeric keypad You can use a Numeric keypad to enter numeric values.
Text keypad You can use a Text keypad to enter text.
MP/GP knob A line between the knob icon and the field indicates which

knob you can turn on the oscilloscope to select a value.
F1 F1 help opens help on a topic associated with the currently

selected item in your software.
xxx

Menu Bar
The menu bar consists of the following menus:

Click these links for information on each of the menus.

File menu

Tests menu

Results menu

Utilities menu

Help menu
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File Menu

Menu selection Description
Recall Default Click File > Recall Default to recall the default settings for

both the software and the oscilloscope.
Recall Click File > Recall to recall the previously saved settings for

the software from an .ini file.
Save Click File > Save to save the software settings to an .ini

file.
Recall Recent Click File > Recall Recent to select among the recently

saved and recalled setups.
Preferences Click File > Preferences to select one of the following

options. Click an option again to clear the selection.

Position Eye Mask in Center

Acquisition Alert Message

Jitter Tolerance (No calibration)

Single Ended (With 50ohm term)

Set the probe control to internal 3.3 V
Minimize Click File > Minimize to minimize the software window.
Exit Click File > Exit to quit the software.
xxx

Click these links for information on the other menus.

Help menu

Results menu

Tests menu

Utilities menu
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Tests Menu

Menu selection Description
Select Click Tests > Select to display or modify the test selection

for Source, Sink, or Cable in the client pane.
Configure Click Tests > Configure to display or modify the configuration

parameters for the selected test(s).
Connect Click Tests > Connect to display the connection instructions

for the selected test(s).
View Waveform Click Tests > View Waveform to display a sample waveform

or waveforms based on the settings for the selected test(s).
xxx

Click these links for information on the other menus.

File menu

Help menu

Results menu

Utilities menu

Results Menu

26 TDSHT3 HDMI Compliance Test Software Online Help



Operating Basics Utilities menu

Menu selection Description
Summary Click Results > Summary to display the result summary of

the last test(s) that you conducted.
Details Click Results > Details to display the detailed results of the

last test(s) that was conducted.
xxx

Click these links for information on the other menus.

File menu

Help menu

Tests menu

Utilities menu

Utilities menu

Menu selection Description
Deskew Click Utilities > Deskew to open the deskew pane. The

deskew pane allows you to compensate the skew between
the oscilloscope channels.

DTG Pattern List Click Utilities > DTG Pattern list to open the DTG Pattern
list pane. The DTG pattern list allows you to add and delete
DTG pattern files.

xxx

Click these links for information on the other menus.

File menu

Help menu

Results menu

Tests menu
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Help menu

Menu selection Description
Help Topics Click Help > Help Topics to display the help file for the

TDSHT3 HDMI Compliance Test Software.
About TDSHT3 Click Help > About TDSHT3 to display a dialog box with

information about the current TDSHT3 HDMI Compliance
Test Software.

xxx

Click these links for information on the other menus.

File menu

Results menu

Tests menu

Utilities menu
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Preferences
On the menu bar, click File > Preferences to select any of the options described in the following table.
Click an option again to clear the selection.

Option Description
Position Eye Mask in Center Select this option to position the mask at the center of the

eye diagram. Clear this option to position the mask to the
left of the eye diagram.

Acquisition Alert Message Select this option to receive an alert message that allows
the software to use the custom oscilloscope setup. Clear
this option to stop receiving the alert message.

Jitter Tolerance (No calibration) Select this option if you do not want to run the jitter
calibration tests for sink jitter tolerance measurements.

Single Ended (With 50 Ω term) This option can be selected only when the negative input of
the probe is terminated with the 50 Ω terminator. When this
option is selected, the single ended measurements will be
performed as though 50 Ω termination is connected.

Set the probe control to internal 3.3 V This option is applicable to Source measurements on
DPO/DSA oscilloscopes with P7313 probes. When this
option is selected, the application sets the probe control to
internal and voltage to 3.3 V.

xxx
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Selection pane
The selection pane, which is located to the left of the software window, allows you to navigate through
the software.

The following table lists the buttons and their task descriptions:

Button name Description
Select Click Tests > Select to display or modify the test selection

for Source, Sink, or Cable in the client pane.
Configure Click Tests > Configure to display or modify the configuration

parameters for the selected test(s).
Connect Click Tests > Connect to display the connection instructions

for the selected test(s).
View Waveform Click Tests > View Waveform to display a sample waveform

or waveforms based on the settings for the selected test(s).
xxx
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Result pane
The result pane, which is located at the center of the software window, appears as shown in the following
figure:

The result pane includes the result summary pane and the report configuration pane.

Result Summary pane
The result summary pane displays the test results.

This icon indicates that the test has passed.

This icon indicates that the test has failed.

This icon indicates that the test could not be run due to an error.

Option Description
Status The status icons display the status of the test as Pass, Fail,

or Error.
Test Name The Test Name box displays the test id, test name, and

selected lanes.
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Option Description
Data Lane Select the data lane pair for which to display the

corresponding eye diagram plot.
View Jitter Plot Click View Jitter Plot to display the jitter plot. This option is

available if you have successfully run the clock jitter test.
View Eye Plot Click View Eye Plot to display the eye plot. This option is

available if you have successfully run the eye diagram test.
Result Details Click Result Details to display the Result Details dialog box

that shows the details of test results categorized as test
name, specification range, measured value, result, and
remarks.

xxx

Report Configuration pane
You can set the report details to identify and generate the report automatically. You can also set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.
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Category Description
Save As Click Save As to save the generated reports. The Save

File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

Execution pane
The execution pane, which is located to the right of the software window, displays the Run Test and Result
buttons. After you successfully run a test, the Summary and Detail buttons are available.

Click each button to perform a particular task. The following table lists the buttons and their task
descriptions:

Button name Description
Run Test Click Run Test to run the selected test or tests.
Result Click Result to display the result pane that shows the test

results.
Summary Click Summary to generate a report summary as a .csv

file.
Detail Click Detail to generate the HTML/MHT report. Plots and

waveforms are displayed where ever applicable.
xxx

Status bar
At the bottom of the software window is the status bar, which displays the selected test and the important
configuration parameters.
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General Purpose Knob
To use the General-Purpose knob, follow these steps:

1. Click any number box to display the connection to one of the general purpose knobs.

2. Turn the corresponding knob on the oscilloscope front panel to adjust the value for the selected
parameter.

3. For better resolution, press the Fine button.

Enable Remote Control of Test Equipment
Three methods are available to connect to an AWG, DTG, or AFG. The methods are GPIB-GPIB
(recommended), GPIB-USB, and GPIB-ENET.

The following section will guide you through the process of connecting the AWG, DTG, AFG , and the
digital oscilloscope used for Sink and Cable tests:

You will need Tektronix AWG7000 series, AFG3000, Tektronix DTG5274/DTG5334, Tektronix supported
oscilloscope, National Instruments GPIB-USB-B with the included software, NI-GPIB-HS cable with the
included software, and NI-488.2 for Windows.

NI-488.2 Software configuration for TDS series
1. Ensure that NI-VISA is NOT installed.

2. Install NI-488.2 for Windows (version 2.1 or later).
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3. Install the Measurement & Automation Explorer software.

4. When prompted, enable the GPIB-USB interface.

NOTE. If you already have NI-488.2 installed on your oscilloscope, then ensure that you have the
appropriate version and installation parameters. Otherwise, remove NI-488.2, and then reinstall the
appropriate version.

5. Restart the oscilloscope.

NI-Software configuration for DPO70000 series

NOTE. If you are using the NI-Drivers on the DPO70000 series for the first time perform steps1 through 9.
If not perform steps 7 through 9.

1. In the oscilloscope menu, click Utilities > GPIB Configuration.
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2. In the GPIB Configuration, select Controller. A GPIB Mode Switch dialog box is displayed.

3. Press OK to restart the oscilloscope.

4. In the oscilloscope menu, click Utilities > GPIB Configuration.

5. In the GPIB Configuration, select Talk/Listen. A GPIB mode switch dialog box is displayed.
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6. Press OK to restart the oscilloscope.

You cannot access the NI software from the Start > Programmenu and will have to go to C:\Program
Files\National Instruments\NI-488.2\Bin location.

7. Double-click Add GPIB Hardware to display the Add GPIB Hardware Wizard.
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8. Select the appropriate NI hardware from the list (select GPIB-USB-B from the list if it is connected).

9. Press Next and finish the installation.

Configure and View Equipment Connections
This section helps you to configure the equipment and view the connections.

1. Configure the DTG GPIB primary address to 1 and AWG/AFG GPIB primary address to 2.

2. Connect the USB-GPIB controller to the USB port on the oscilloscope. The oscilloscope operating
system will detect the USB-GPIB controller and install the appropriate driver for it.

3. Using GPIB cables, connect (stack) both the DTG and AWG/AFG GPIB ports to the GPIB port of
the GPIB controller.

4. Open the Measurement & Automation Explorer software that was installed with the NI-488.2 software.
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5. In the configuration pane, look under Devices and Interfaces for the GPIB device.

6. Right-click the GPIB device and click Scan for Instruments.

7. Note the GPIB Instrument Number and the Primary Address to configure the instrument connection in
the TDSHT3 HDMI Compliance Test Software.

8. Right-click the instrument, and then click Communicate with Instrument.

9. In the NI-488.2 Communicator dialog box, click Query and check that “*IDN?” displays a description
of the correct equipment.

10.Start the TDSHT3 HDMI Compliance Test Software.

11.Click Select.

12.Click the Sink tab.

13.Select one of the differential tests, such as Jitter Tolerance.
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14.Click Connect.

15.Click Signal Sources. The Signal Sources Setup dialog box appears.

16.In the Signal Sources Setup dialog box, click the DTG tab.

17.Configure the GPIB Board Type by using the GPIB Instrument Number that you noted in step 4.

18.Configure the Primary Address by using the address that you noted in step 4.

19.Leave the Secondary Address set to 0.

20.Click AWG tab and repeat steps 14 through 16 for the AWG.

21.Click AFG tab and repeat steps 14 through 16 for the AFG.

22.Click Test Conn and look for a message that the connection is successful.

Configure New IP Address for GPIB-ENET
There are two methods to connect to AWG/DTG. One is the GPIB-USB method and the other, the
GPIB-ENET method.

GPIB-ENET and GPIB-ENET/100 for Windows 3.1/95/98/ME/NT/2000/XP
1. Confirm that you have installed the latest NI-488.2 driver software for your device.

2. Connect your GPIB-ENET or GPIB-ENET/100 to an Ethernet network by using a category 5 Ethernet
cable to connect the RJ-45 port on your hardware to an Ethernet hub. You could also connect the
external hardware directly to your oscilloscope by using an Ethernet crossover cable.
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3. Connect the power to your GPIB-ENET or GPIB-ENET/100 and turn it on. When you power on
your GPIB-ENET, the POWER LED comes on immediately. The READY LED flashes while it
completes its power-on self-test. When the test completes successfully and the IP address is assigned,
the READY LED remains steady, indicating that the unit is ready to operate. To assign your IP
address, continue to step 4.

4. Run the Measurement & Automation Explorer software from Programs > National Instruments.

5. Some devices are not Windows Plug and Play compatible. Hence, they do not automatically appear in
the Devices and Interfaces list. Other devices may reside in another oscilloscope on your network. To
add non Plug and Play or remote DAQ devices, right-click Devices and Interfaces in the configuration
tree, and then clickCreate New. Follow the instructions in the wizard. Select GPIB-ENET/100 or
GPIB-ENET interface according to the hardware.

How to Configure GPIB-ENET/100
1. To configure an existing National Instruments device, right-click the device name in Devices and
Interfaces in the configuration tree, and then click Properties. You can also configure existing device
properties by clicking Properties in the toolbar.

2. To configure the network parameters of your GPIB-ENET/100, right-click your GPIB interface in the
configuration tree, and click Device Configuration.

3. Click Properties. Configure the IP address as shown in the following figure:
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Operating Basics Configure New IP Address for GPIB-ENET

4. After entering the IP settings, click OK. A message box appears as follows:

5. After you reset the CFG in the ENET card, click OK in the GPIB-ENET/100 Properties message box.
The software will configure and another message box appears.

6. Click OK. The ENET card is configured.

7. Verify the configuration by pinging the IP address and through ICTA.

How to Configure GPIB-ENET (old card)
1. Right-click Devices and Interfaces. Click Assign IP Address. A message box appears.
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NOTE. The GPIB software installation is in the path C:\Program Files\National
Instruments\NI-488.2\GPIB-ENET on the oscilloscope.

2. Run the Measurement & Automation Explorer software. Click Assign IP Address. A message box
appears.

3. Enter the new IP Address and the Ethernet Address. Click Assign. A message box appears.

4. Follow the instructions in the Ipassign message box. Click OK. Another message box appears.
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5. Follow the instructions in the new Ipassign message box. Click OK.

Remote Control Caution
If you run the Sink or Cable tests, the GPIB Bus Timing dialog box appears.

Click OK to continue if you are sure that the Bus Timing parameter is already set to 2 µsec. Otherwise,
click Cancel and follow the procedure outlined on later to change the Bus Timing parameter manually.

Once you have changed the parameter, select the check box if you do not want the dialog box to appear
again in the current session. However, if you click File > Recall Default or you quit the software, then the
dialog box appears again when you run the test.

When you install the remote control for the test equipment, the Measurement & Automation Explorer
software will be installed on the oscilloscope. You can start the software by clicking Start > Program
Files > National Instruments > Measurement & Automation.
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To change the Bus Timing parameter, perform the following steps:

1. Start the Measurement & Automation Explorer software.

2. In the configuration pane, look under Devices and Interfaces for the GPIB device.

3. Right-click the GPIB device and click Properties. The GPIB Configuration dialog box appears.

4. In the GPIB Configuration dialog box, click the Advanced tab.

5. In the Bus Timing list, select 2 µsec.

6. Quit the TDSHT3 HDMI Compliance Test Software and restart the oscilloscope.
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Remote GPIB Commands
The Remote General Purpose Interface Bus (RGPIB) is essentially another way of interfacing with the
oscilloscope. It allows you to control much of the functionality of the oscilloscope as defined by the
software, from a Remote GPIB controller.

You can use the following GPIB command to start the TDSHT3 HDMI Compliance Test Software:

application:activate “HDMI Compliance Test Software(1.3)”

How to Set and Query
1. The following command syntax sets the value to the variable:

VARIABLE:VALUE “<variable name>”,“<variable value>”

The arguments <variable name> and <variable value> are required in the order indicated.

2. The following command syntax queries the value of the variable:

VARIABLE:VALUE? “<variable name>”

3. The following command syntax runs the selected test:

VARIABLE:VALUE “sequencerState”, “Sequencing”

The TDSHT3 HDMI Compliance Test Software will be remotely controllable for the following set of
commands for (VARIABLE:VALUE):

Application

Variable name Valid values Function (Set) Query form
Application exit Set the value to quit a

running the software.
Query to return the name
of the currently running
software.

version - - Query to return the version
of the currently running
software, for example,
Version: 1.0.0.

xxx

Sequencer

Variable name Valid values Function (Set) Query form
sequencerState { Sequencing}: to set

{Ready, Sequencing}:
returned on query

Set the sequencer state. Return the sequencer
state.

xxx
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Save/Recall

Variable name Valid values Function (Set) Query form
setup {Default, Recall, Save} Set the Save/Recall/Default

action.
Default value for this
variable is an empty string.
Thus, the variable is set to
selected value momentarily
and after the task is
completed, it returns to its
default value.

recallName Any string 1-8 chars,
comprised of A-Z , 0-9

Set the setup recall file
name.

Return the setup recall file
name.

saveName Any string 1-8 chars,
comprised of A-Z , 0-9

Set the setup save file
name.

Return the setup save file
name.

xxx

Report

Variable name Valid values Function (Set) Query form
reportSummary Save Save the report summary

to a .csv file.
-

reportDetail Save Save the report details to a
.mht file.

-

xxx

Result Details
After the test is complete, on the result pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column describes the HDMI standards

and test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
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Options Description
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the results of

Tbit, Vswing, and Margin. If the test could not be run, then
an error code appears.

Close Click Close to quit the Result Details dialog box.
View Jitter Plot Click View Jitter Plot to display the jitter plot. This option is

available if you have successfully run the clock jitter test.
View Eye Plot Click View Eye Plot to display the eye plot. This option is

available if you have successfully run the eye diagram test.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

NOTE. The parameters in the Result Details dialog box may change depending on the test that you run.

Virtual Keyboard

Virtual Keyboard - Numeric
1. Click any number box to display the icon for the numeric keyboard.

2. Click the icon to display the numeric keyboard.
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3. Click the number keys to enter the desired value.

4. Select a unit of measure.

5. Click Enter to confirm your entry. Selections are not effective until you click Enter.

Virtual Keyboard - Text
1. Click New to display the virtual keyboard.

2. Use the text keyboard to enter the required text (such as a file name).
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3. Click Enter to confirm your entry. Selections are not effective until you click Enter.

Exit
To quit the software:

1. On the menu bar, click File > Exit.

2. The Exit dialog box appears.

3. Click either Yes, No, or Cancel. Yes is selected by default. While the software is running, it
automatically changes some oscilloscope settings. When you quit the software, you can choose whether
to retain these settings or restore the previous settings.

NOTE. Using other methods to quit the software may result in an abnormal termination of the software.
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Calculate Tbit
On the Menu bar, click Test > Configure after the measurement is selected from the Select screen.

Tbit is the time that is required to transmit one bit of data. Tbit is one bit time at the specified pixel
clock frequency (= TPIXEL/10).

For all the tests that require clock, the software calculates Tbit. For all the other tests, you have an option
of either recalculating Tbit or use the previous Tbit value for the test.

If you click Re-calculate, the software computes the specified number of averages of TPIXEL and then
calculates Tbit. If you use the existing Tbit value, then the software uses the previously calculated Tbit
value or you can again recalculate Tbit by using the Tbit pane.

To calculate Tbit for a test, use the Tbit pane. You can calculate Tbit for Rise Time, Fall Time, Inter-Pair
Skew, Source Intra-Pair Skew, Low Amplitude +, Low Amplitude –, and Sink Intra-Pair Skew test if the
clock is not connected.
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To Calculate Tbit
1. Set up the connections as shown in the following diagram:

Setup 1: Connections to calculate Tbit
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Setup 2: Connections to calculate Tbit with Efficere Test Fixture

Connect an TPA-P-DI adapter to a Source DUT HDMI output connector.

Connect a power supply to a TPA board.

Configure the Source DUT to output a video format with the required supported pixel clock
frequency.

Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

2. In the Tbit pane, you have the following options:
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Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

NOTE. Tbit value is used for oscilloscope setup and limit calculations. If the DUT’s display resolution and
the refresh rate changes, you have to recalculate Tbit.

Deskew
Deskew is recommended before you conduct any skew test. To ensure accurate results, deskew the test
setup before you conduct the tests from your device under test.

1. On the menu bar, click Utilities > Deskew.

2. In the source pane, you have the following options:

Configure parameter Description
External Click External if you will use an external signal source (such

as the clock signal of DUT).
Internal Click Internal to probe the compensation signal on an

oscilloscope.
xxx

3. Select the input channels between which you want to perform the deskew operation. Hysteresis and Ref
Level are available only for an external source.
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4. In the slope pane, you have the following options:

Configure parameter Description
Rise Click Rise to calculate the average of the number of slopes

and then set the skew for a rising pulse.
Fall Click Fall to calculate the average of the number of slopes

and then set the skew for a falling pulse. You do not have to
calculate the average of the number of slopes for a falling
pulse for an internal source.

# of Slopes In the # of Slopes box, enter the required number of slopes
to enable to set the skew for either a rising pulse or a falling
pulse. Ensure that the required number of slopes is present
in the acquisition.

xxx

5. Set up the oscilloscope as follows:

Set the acquisition rate so that there are two or more samples on the deskew edge using the
horizontal scale knob.

Adjust the signals and display them on the screen using the vertical scale and position knobs.

Set the record length so that there are more samples for the edges in the acquisition.

6. Click Run Test to deskew the probes.

Configure-DTG Pattern List
1. On the menu bar, click Utilities > DTG Pattern List.

2. In the Pattern pane, the Available Patterns drop-down list displays all the available patterns (including
the newly added ones). The DTG pattern selected from the Configure screen is displayed as the default
pattern in the Available Patterns list.

3. Click New to add a new DTG pattern. Type the name of the pattern and click Enter to save the pattern.
All the newly added patterns will be available in Cable Eye Diagram, Sink Min/Max Diff, and Sink
Jitter Tolerance measurements. The newly added pattern files should have a.dtg extension.
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4. You can delete an added pattern by selecting the pattern from the Available Patterns list. Click Selected
to delete the selected pattern. The default patterns installed by the application cannot be deleted.

NOTE. All the folders of the application should have unique DTG pattern names.

Source

The following table shows how to select the source test parameters:

Test type How to select
Source Click Tests > Select > Source to select the source tab.
Differential Tests
Eye Diagram In the Source tab, select the Eye Diagram check box.
Duty Cycle In the Source tab, select the Duty Cycle check box.
Rise Time In the Source tab, select the Rise Time check box.
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Test type How to select
Fall Time In the Source tab, select the Fall Time check box.
Clock Jitter In the Source tab, select the Clock Jitter check box.
Inter-Pair Skew In the Source tab, select the Inter-Pair Skew check box.
Select All In the Source tab, click Select All to select multiple tests

for Differential Tests. When you select more than one test,
Select All changes to Clear All.

Single-Ended Tests
Intra-Pair Skew In the Source tab, select the Intra-Pair Skew check box.
Low Amplitude + In the Source tab, select the Low Amplitude + check box.
Low Amplitude – In the Source tab, select the Low Amplitude – check box.
Select All In the Source tab, click Select All to select multiple tests for

Single-Ended Tests. When you select more than one test,
Select All changes to Clear All.

xxx

Sink

The following table shows how to select the sink test parameters:

Test type How to select
Sink Click Tests > Select > Sink to select the sink tab.
Differential Tests
Min/ Max-Diff Swing Tolerance In the Sink tab, select the Min/ Max-Diff Swing Tolerance

check box.
Jitter Tolerance In the Sink tab, select the Jitter Tolerance check box.
Single-Ended Tests
Intra-Pair Skew In the Sink tab, select the Intra-Pair Skew check box.
xxx
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Cable

The following table shows how to select the cable test parameters:

Test type How to select
Cable Click Tests > Select > Cable to select the cable tab.
Eye Diagram In the Cable tab, select the Eye Diagram check box.
xxx

Source
On the menu bar, click Tests > Configure to configure the parameters for the selected test(s).

In the configure pane, you will see the factory default configuration for the test you selected. For most
tests, you can use the factory default configuration. However, you can change the values by using the
virtual keyboard or the general purpose knob on the oscilloscope front panel. Using the File menu, you can
also restore the factory defaults or save and recall your own configuration settings. It is recommended that
you save the configuration settings before you choose to select Recall Default or close the application. For
more information about configuration, refer to How to... Test and go to a specific test.

The following table shows the parameters that you can configure for source (differential tests):
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The following table shows the parameters that you can configure for source (single-ended tests):
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Sink
On the menu bar, click Tests > Configure to configure the parameters for the selected test.

In the configure pane, you will see the factory default configuration for the test you selected. For most
tests, you can use the factory default configuration. However, you can change the values by using the
virtual keyboard or the general purpose knob on the oscilloscope front panel. Using the File menu, you can
also restore the factory defaults or save and recall your own configuration settings. It is recommended that
you save the configuration settings before you choose to select Recall Default or close the application. For
more information about configuration, refer to How to... Test and go to a specific test.

The following table shows the parameters that you can configure for sink (differential tests):
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The following table shows the parameters that you can configure for sink (single-ended tests):

Cable
On the menu bar, click Tests > Configure to configure the parameters for the selected test.

In the configure pane, you will see the factory default configuration for the test you selected. For most
tests, you can use the factory default configuration. However, you can change the values by using the
virtual keyboard or the general purpose knob on the oscilloscope front panel. Using the File menu, you can
also restore the factory defaults or save and recall your own configuration settings. It is recommended that
you save the configuration settings before you choose to select Recall Default or close the application. For
more information about configuration, click the How to...Test help topic, and then go to the specific test.

The following table shows the parameters that you can configure for cable (differential tests):
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EDID Emulator for Source Tests
The EDID-PCB or EDID Emulator can be used in the following Source connection diagrams.
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Eye Diagram (Source)
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.

Method 1: Connections for Source Eye Diagram
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Method 2: Connections for Source Eye Diagram with Efficere Test Fixture

64 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Eye Diagram (Source)

For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-TDR/ ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect a TMDS Clock to the configured oscilloscope channel by using a SMA differential probe.

5. Connect the TMDS_DATA pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a SMA differential probe.

6. Configure the Source DUT to output the required video format.

Duty Cycle
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.
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Method 1: Connections for Source Duty Cycle
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Method 2: Connections for Source Duty Cycle with Efficere Test Fixture

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).
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4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Rise Time
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.

Method 1: Connections for Source Rise Time
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Method 2: Connections for Source Rise Time with Efficere Test Fixture
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For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ ET-TPA-P adapter

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a differential probe(s) to a TMDS_DATA/CLOCK.

6. If you have selected “Re-calculate Tbit” in the configuration pane, then connect the clock channel to
the configured oscilloscope channel by using a second differential probe(s).

Fall Time
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.

Method 1: Connections for Source Fall Time
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Method 2: Connections for Source Fall Time with Efficere Test Fixture
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For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the highest supported pixel clock frequency.

5. Connect a differential probe(s) to TMDS_DATA/CLOCK.

6. If you have selected “Re-calculate Tbit” in the configuration pane, then connect the clock channel to
the configured oscilloscope channel by using a second differential probe(s).

Clock Jitter
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.
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Method 1: Connections for Source Clock Jitter
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Method 2: Connections for Source Clock Jitter with Efficere Test Fixture

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).
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4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Inter-Pair Skew
On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests for EDID emulator
connections.

Setup 1
Use this setup if you selected “Re-calculate Tbit” in the configuration pane.

Make the connection as follows:
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Method 1: Connections for Inter-Pair Skew (Re-calculate Tbit option selected)
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Method 2: Connections for Inter-Pair Skew with Efficere Test Fixture (Re-calculate Tbit option
selected)

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you selected “Existing Tbit” value or if you are calculating the inter-pair skew.

Make the connection as follows:

Method 1: Connections for Source Inter-Pair Skew (Existing Tbit option selected)
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Method 2: Connections for Source Inter-Pair Skew with Efficere Test Fixture (Existing Tbit option
selected)
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For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the set to enable the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the TMDS_CLOCK to the configured oscilloscope channel by using a differential probe.

5. Connect a TMDS_DATA<X> to the configured oscilloscope channel by using a second differential
probe.

6. Connect the TMDS_DATA<Y> pair on which you will conduct the test to the configured oscilloscope
channel by using a third differential probe.

7. Connect the TMDS_DATA<Z> pair on which you will conduct the test to the configured oscilloscope
channel by using a fourth differential probe.

8. Configure the Source DUT to output the required video format.

Differential Tests Select All
On the menu bar, click Tests > Connect and make the connection as follows. Refer to EDID Emulator
for Source Tests for EDID emulator connections.
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Method 1: Connections for Source Differential tests (with Select All option)

TDSHT3 HDMI Compliance Test Software Online Help 85



How to ... Differential Tests Select All

Method 2: Connections for Source Differential tests with Efficere Test Fixture (Select All option)
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For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

5. Connect the TMDS_DATA pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).

6. Configure the Source DUT to output the required video format.

Intra-Pair Skew (Source)
On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests for EDID emulator
connections.

Setup 1
Use this setup if you have selected “Re-calculate Tbit” in the configuration pane.

Make the connection as follows:
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Method 1: Connections for Source Intra-Pair Skew test (Re-calculate Tbit option selected)
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Method 2: Connections for Source Intra-Pair Skew test with Efficere Test Fixture (Re-calculate
Tbit option selected)

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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How to ... Intra-Pair Skew (Source)

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you have selected “Existing Tbit” value or if you are calculating the intra-pair skew.

Make the connection as follows:

Method 1: Connections for Source Intra-Pair Skew test (Existing Tbit option selected)

TDSHT3 HDMI Compliance Test Software Online Help 91



How to ... Intra-Pair Skew (Source)

Method 2: Connections for Source Intra-Pair Skew test with Efficere Test Fixture (Existing Tbit
option selected)
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How to ... Intra-Pair Skew (Source)

For 4-Channel

1. Connect the HDMI output of the source DUT to the TPA-P-SE/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the first single-ended probe to TMDS_DATA<X>+/TMDS_CLOCK+.

5. Connect the second single-ended probe to TMDS_DATA<X>– /TMDS_CLOCK–.

6. Connect the third single-ended probe to TMDS_DATA<X>+/TMDS_CLOCK+.

7. Connect the fourth single-ended probe to TMDS_DATA<X>– /TMDS_CLOCK–.

8. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Low Amplitude +
On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests for EDID emulator
connections.

Setup 1
Use this setup if you have selected “Re-calculate Tbit” in the configuration pane.

Make the connection as follows:
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How to ... Low Amplitude +

Method 1: Connections for Low Amplitude + (Re-calculate Tbit option selected)
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How to ... Low Amplitude +

Method 2: Connections for Low Amplitude + with Efficere Test Fixture (Re-calculate Tbit option
selected)

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you have selected “Existing Tbit” value or if you are calculating low amplitude.

Make the connection as follows:

Method 1: Connections for Low Amplitude + (Existing Tbit option selected)
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Method 2: Connections for Low Amplitude + with Efficere Test Fixture (Existing Tbit option selected)
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For 4-Channel

NOTE. Connecting CH2 and Ch4 is not a must for this measurement.

1. Connect the HDMI output of the source DUT to the TPA-P-SE/ ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.
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How to ... Low Amplitude -

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the first single-ended probe to TMDS_DATA<X>+/ TMDS_CLOCK+.

5. Connect the second single-ended probe to TMDS_DATA<X>+/ TMDS_CLOCK+.

6. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Low Amplitude -
On the menu bar, click Tests > Connect. Refer to EDID Emulator for Source Tests for EDID emulator
connections.

Setup 1
Use this setup if you have selected “Re-calculate Tbit” in the configuration pane.

Make the connection as follows:
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Method 1: Connections for Low Amplitude – (Re-calculate Tbit option selected)
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How to ... Low Amplitude -

Method 2: Connections for Low Amplitude – with Efficere Test Fixture (Re-calculate Tbit option
selected)

1. Connect the HDMI output of the source DUT to the TPA-P-DI/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 3.30 V.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.
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3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Connect a TMDS Clock to the configured oscilloscope channel by using a differential probe.

Setup 2
Use this setup if you have selected “Existing Tbit” value or if you are calculating low amplitude.

Make the connection as follows:

Method 1: Connections for Low Amplitude - (Existing Tbit option selected)

TDSHT3 HDMI Compliance Test Software Online Help 103



How to ... Low Amplitude -

Method 2: Connections for Low Amplitude - with Efficere Test Fixture (Existing Tbit option selected)

104 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Low Amplitude -

For 4-Channel

NOTE. Connecting Ch1 and Ch3 is not a must for this measurement.

1. Connect the HDMI output of the source DUT to the TPA-P-SE/ET-TPA-P adapter.

2. Connect a power supply to the TPA adapter and set the power supply to 0 V.
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How to ... Min/Max-Diff Swing Tolerance

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

3. Connect the EDID emulator to the TPA adapter and set the emulator for the required resolution (refer
to the EDID emulator user manual).

4. Connect the first single-ended probe to TMDS_DATA<X>+/ TMDS_CLOCK+.

5. Connect the second single-ended probe to TMDS_DATA<X>–/ TMDS_CLOCK–.

6. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

Min/Max-Diff Swing Tolerance
NOTE. For all the old test fixture connections, connect a TTC filter in between the DTG and the test fixture.

On the menu bar, click Tests > Connect.

Method 1: Using old fixtures
Setup 1: To find the minimum swing voltage of the Sink DUT

Make the connection as follows:
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How to ... Min/Max-Diff Swing Tolerance

NOTE. Using the Cable Emulator/Cable is not mandatory. You can connect a TPA-P-TDR fixture directly to
the DUT. If you find this inconvenient, then use the Cable Emulator/Cable to connect the DUT conveniently.

1. Connect the DTG to the TPA-R-TDR by using eight one meter or one and a half meter SMA cables:

Module A, Channel 1+, 1-: Connect to CLOCK_P, and CLOCK_N

Module A, Channel 2+, 2-: No Connection

Module B, Channel 1+, 1-: Connect to DATA0_P and DATA0_N

Module B, Channel 2+, 2-: Connect to DATA1_P and DATA1_N

Module C, Channel 1+, 1-: Connect to DATA2_P and DATA2_N

Module C, Channel 2+, 2-: No Connection

2. Connect the Cable Emulator from the TPA-R-TDR to the Sink DUT.

3. Connect and configure the DC Power Supply to drive +5 V between +5 V Power (P_5V) and DDC
/CEC Ground ( P_GND) on the TPA-R-TDR.

Setup 2: To measure the minimum differential swing voltage by using an oscilloscope
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How to ... Min/Max-Diff Swing Tolerance

Make the connection as follows:

1. Remove the Sink DUT from the Cable Emulator.

2. Connect the TPA-R-DI test fixture at the end of the Cable Emulator.

3. Connect a TMDS Clock/Data channel to the configured oscilloscope channel by using a differential
probe.

Setup 3: To find the maximum swing voltage of the Sink DUT

1. Remove the TPA-R-DI text fixture at the end of the Cable Emulator.

2. Connect the Sink DUT to the Cable Emulator.
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Method 2: Using Efficere test fixtures
Setup 1 : To find the Min/Max differential swing voltage of the Sink DUT with Efficere Test Fixture
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Setup 2 : To measure the Min/Max differential swing voltage of the Sink DUT with Efficere Test Fixture

110 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Jitter Tolerance

Jitter Tolerance
NOTE. For all the old test fixture connections, connect a TTC filter in between the DTG and the test fixture.

On the menu bar, click Tests > Connect.

Method 1: Using old fixtures
Setup 1: To find the device tolerance limit for frequencies < 148.5 MHz make the connections as follows:
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1. Connect the DTG, AWG, Bias-Tees, and the TPA-R-TDR.

AWG Marker 1+ output to DTG External Clock input

AWG Marker 2+ output to DTG Trigger In

AWG Ch. 1+ output to Bias-Tee signal input (RF)

Bias-Tee signal output (RF and DC) to CLOCK_P

DTG DC_OUT (1) to Bias-Tee DC-level input (DC)

AWG Ch. 1- output to Bias-Tee signal input (RF)

Bias-Tee signal output (RF and DC) to CLOCK_N

DTG DC_OUT (2) to Bias-Tee DC-level input (DC)

DTG Module A, Channel 1+, 1–: No Connection

DTG Module A, Channel 2+, 2–: No Connection

DTG Module B, Channel 1+, 1–: Connect to DATA0_P and DATA0_N

DTG Module B, Channel 2+, 2–: Connect to DATA1_P and DATA1_N

DTG Module C, Channel 1+, 1–: Connect to DATA2_P and DATA2_N

DTG Module C, Channel 2+, 2–: No Connection

2. Connect the TPA-R-TDR to the Sink DUT by using a Cable Emulator specified for tested pixel
clock rate.

3. Connect and configure the DC Power Supply to drive +5 V between +5 V Power (P_5V) and DDC/CEC
Ground (P_GND) on the TPA-R-TDR.

Setup 2: To measure the parameters for frequencies < 148.5 MHz make the connections as follows:
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How to ... Jitter Tolerance

1. Remove the Sink DUT.

2. Connect the TPA-R-DI test adaptor to a Cable Emulator.

3. Connect a Clock to the configured oscilloscope channel by using a differential probe.

4. Connect the DATA pair on which you will conduct the test to the configured oscilloscope channel
by using a second differential probe.

Method 2: Using Efficere test fixtures
Connections for jitter calibration (common to all jitter insertion setups)
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How to ... Jitter Tolerance

1. Use Jitter Generation block to generate a known amount of jitter (Clock jitter: 0.25 UI, Data jitter:
0.30 UI).

2. Connect the test fixture to the oscilloscope for calibration. The oscilloscope calculates data and clock
jitter inserted due to the cables and the test fixtures along with the known amount of jitter.

Connections to adjust the clock jitter at TP2
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How to ... Jitter Tolerance

Setup 1a: DTG-AWG710/AWG710B for testing resolutions ≤ 74.25MHz
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How to ... Jitter Tolerance

1. Connect the test equipment for DTG and AWG connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

Setup 1b: DTG-AWG710/AWG710B for testing resolutions > 74.25MHz
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How to ... Jitter Tolerance

1. Connect the test equipment for DTG and AWG connection as shown in the setup diagram.

2. Connect the DTG, AWG, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

3. Configure the DUT to receive the HDMI input signal.

NOTE. Some of the DUTs work with test fixtures that are not connected to a power supply.

Setup 2: DTG-AFG3000 jitter tolerance
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How to ... Jitter Tolerance

1. Connect the test equipment for DTG and AFG connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AFG, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

Setup 3: DTG-AWG7102 composite jitter tolerance for all frequencies
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How to ... Jitter Tolerance

1. Connect the test equipment for DTG and AWG7102 connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG7102, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

NOTE. Mkr2 need not be connected to the trigger input of the DTG.

Setup 4: DTG-AWG7102 separate jitter tolerance for all frequencies
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How to ... Intra-Pair Skew (Sink)

1. Connect the test equipment for DTG and AWG7102 connection as shown in the setup diagram.

2. When connecting the test fixture to the DUT, use a cable emulator specified for the pixel clock rate
being tested.

3. Connect the DTG, AWG7102, and the oscilloscope according to the Enable Remote Control of Test
Equipment procedure.

4. Configure the DUT to receive the HDMI input signal.

Intra-Pair Skew (Sink)
NOTE. For all the old test fixture connections, connect a TTC filter in between the DTG and the test fixture.

On the menu bar, click Tests > Connect.
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How to ... Intra-Pair Skew (Sink)

NOTE. The procedure mentioned next is for the clock intra-pair skew test. For other pairs, interchange the
connection of DATA <X>_P with CLOCK_P and DATA <X>_N with CLOCK_N. Make the appropriate
changes in the configuration of the DTG Outputs accordingly.

For example, to calculate the intra-pair skew of Data0:

Connect DATA0_P to Module A1+, DATA0_N to DTG Module A2+, CLOCK_P to Module B1+, and
CLOCK_N to module B1-.

Method 1: Using old fixtures
Setup 1: To measure Tbit

Make the connection as follows:

NOTE. Use channel of the DTG instead of channel A2 (shown in figure) to make connections for
Tbit measurements.
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How to ... Intra-Pair Skew (Sink)

NOTE. Using the Cable Emulator/Cable is not mandatory. You can connect a TPA-P-TDR fixture directly to
the DUT. If you find this inconvenient, then use the Cable Emulator/Cable to connect the DUT conveniently.

1. Connect the DTG to the TPA-R-TDR by using eight one meter (preferable) or one and a half meter
SMA cables:

Module A, Channel 1+: Connect to CLOCK_P

Module A, Channel 1-: No Connection

Module A, Channel 2+: Connect to CLOCK_N

Module A, Channel 2-: No Connection

Module B, Channel 1+, 1–: Connect to DATA0_P and DATA0_N

Module B, Channel 2+, 2–: Connect to DATA1_P and DATA1_N

Module C, Channel 1+, 1–: Connect to DATA1_P and DATA1_N

Module C, Channel 2+, 2–: No Connection

2. Connect the TPA-R-TDR to the Cable Emulator.

3. Connect the TPA-R-DI to the Cable Emulator.

4. Connect a Clock to the configured oscilloscope channel by using a differential probe.

Setup 2: To find intra-pair skew of the Sink DUT

Make the connection as follows:
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How to ... Intra-Pair Skew (Sink)

NOTE. Using the Cable Emulator/Cable is not mandatory. You can connect a TPA-P-TDR fixture directly to
the DUT. If you find this inconvenient, then use the Cable Emulator/Cable to connect the DUT conveniently.

1. Remove the TPA-R-DI test fixture from the Cable Emulator.

2. Connect the Sink DUT to the Cable Emulator.

3. Connect and configure the DC Power Supply to drive +5 V between +5 V Power (P_5V) and DDC/CEC
Ground (P_GND) on the TPA-R-TDR.

Method 2: Using Efficere test fixtures
Setup 1: To find intra-pair skew of the Sink DUT with Efficere Test Fixture

Make the connections as follows:
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Eye Diagram (Cable)
On the menu bar, click Tests > Connect.

Setup diagram for TP1
Make the connection as follows:
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How to ... Eye Diagram (Cable)

Method 1: Using old fixtures
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How to ... Eye Diagram (Cable)

Method 2: Using Efficere test fixtures
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How to ... Eye Diagram (Cable)

For 4-Channel
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How to ... Eye Diagram (Cable)

For 4-Channel with AFG Jitter Insertion

1. Connect the DTG to the “input” TPA-P-TDR/ET-TPA-P adapter by using eight one meter (preferable)
or one and a half meter SMA cables:

Module A, Channel 1+, 1–: Connect to CLOCK_P and CLOCK_N

Module A, Channel 2+, 2–: No Connection

Module B, Channel 1+, 1–: Connect to DATA0_P and DATA0_N

Module B, Channel 2+, 2–: Connect to DATA1_P and DATA1_N

Module C, Channel 1+, 1–: Connect to DATA2_P and DATA2_N

Module C, Channel 2+, 2–: No Connection

2. Connect the oscilloscope to the “output” TPA-R-DI adapter by using two/four differential probes, and
supply 3.3 V power.
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How to ... Eye Diagram (Cable)

3. Connect a TMDS CLOCK to the configured oscilloscope channel by using a differential probe.

4. Connect the TMDS_DATA pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).

Setup diagram for TP2
Make the connection as follows:

Method 1: Using old fixtures
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How to ... Eye Diagram (Cable)

Method 2: Using Efficere test fixtures
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How to ... Eye Diagram (Cable)

For 4-Channel
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How to ... Eye Diagram (Cable)

For 4-Channel with AFG Jitter Insertion

1. Remove the TPA-P-DI/ET-TPA-P test adaptor.

2. Connect the Cable DUT.

3. Connect the TPA-R-DI test adaptor.

4. Connect a TMDS CLOCK to the configured oscilloscope channel by using a differential probe.

5. Connect the TMDS_DATA pair(s) on which you will conduct the test to the configured oscilloscope
channel by using a second differential probe(s).
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Eye Diagram (Source)
Click View Waveform to display the input signals Clock and Data as follows:
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How to ... Duty Cycle

Duty Cycle
Click View Waveform to display the Clock signal as follows:
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How to ... Rise Time

Rise Time
Click View Waveform to display the input signals Clock or Data as follows:
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Fall Time
Click View Waveform to display the input signals Clock or Data as follows:
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Clock Jitter
Click View Waveform to display the Clock signal as follows:
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How to ... Inter-Pair Skew

Inter-Pair Skew
Click View Waveform to display the input signals Data+ and Data– , Clock as follows:
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How to ... Differential Tests Select All

Differential Tests Select All
Click View Waveform to display the input signals Clock and Data as follows:

NOTE. Similarly, click View Waveform to display a waveform for Single-Ended Tests Select All.
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How to ... Intra-Pair Skew (Source)

Intra-Pair Skew (Source)
Click View Waveform to display the input signals Data+ or Data–/Clock as follows:
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How to ... Low Amplitude +

Low Amplitude +
Click View Waveform to display the input signals Data+ or Data–/Clock as follows:
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How to ... Low Amplitude -

Low Amplitude -
Click View Waveform to display the input signals Data+ or Data–/Clock as follows:

Min/Max-Diff Swing Tolerance
Because no signal is connected to the oscilloscope, you cannot view the waveform for the Min/Max-Diff
Swing Tolerance test.

Jitter Tolerance
Because no signal is connected to the oscilloscope, you cannot view the waveform for the Jitter Tolerance
test.
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Intra-Pair Skew (Sink)
Because no signal is connected to the oscilloscope, you cannot view the waveform for the Intra-Pair
Skew test.

Eye Diagram (Cable)
Because no signal is connected to the oscilloscope, you cannot view the waveform for the Eye Diagram test.

Eye Diagram (Source)
This test allows you to confirm that the differential signal on each TMDS differential data pair has an “eye
opening” (region of valid data) which meets or exceeds the limits on eye opening in the specification.

You will need one supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Eye Diagram check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
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How to ... Eye Diagram (Source)

defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

4. In the input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, and Ref4.

Data0 Data0 indicates the source channel to which you will connect
the HDMI data0 input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 and Not Conn.

Data1 Data1 indicates the source channel to which you will connect
the HDMI data1 input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 and Not Conn.

Data2 Data2 indicates the source channel to which you will connect
the HDMI data2 input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, Ref4 and Not Conn.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
Record Length In the Rec Length box, enter the desired record length value

for the eye tests.
xxx

6. In the CRU pane, you have the following option:

Configure parameter Description
CRU The CRU list allows you to configure the Clock Recovery

Unit. The available choices are PLL, Raw, and Ideal. The
default value is first order PLL and is used for compliance
testing. Raw and Ideal are used for analysis.

xxx

7. In the reference levels pane, you have the following options:
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Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.
The hysteresis range is between 2 percent and 10 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.
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10.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.

11. If you have run the eye diagram test successfully, the software makes Result available automatically
and displays the eye diagram plot.
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NOTE. In the full screen mode, the histogram disappears if you click anywhere within the plot.

The name of the buttons available on the eye diagram plot and their descriptions are as follows:

Options Description
Save Image Click Save Image to save the eye diagram plot.
Zoom-In Click the Zoom-In icon to zoom the area of interest. You

can zoom up to five times the normal view. Either drag the
mouse or click to zoom in to define the area of interest.

Zoom-Out Click the Zoom-out icon to zoom out.
Reset Plot Click Reset Plot to reset the plot.
Hist Click Hist to draw the histogram.
Hist Limits Click Hist Limits to draw the histogram box.
Hist Save Click Hist Save to save the histogram.
Fix Scale Click Fix Scale to allow the user to type a new scale value.
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Options Description
Enter Scale Click Enter Scale to allow the user to type a new scale

value in the Vertical Scale box.
Mark Hits Click Mark Hits to mark the hits in the eye diagram plot.
Mask Marg Click Mask Marg to display the margins on the eye

diagram plot.
Mask Fit Click Mask Fit to enable to move the mask either in the

left or the right direction. Mask Marg and Mask Fit are
mutually exclusive of each other.

Mask Manual Fit pane You can use this pane to move the mask either in the
left or the right direction. You can select either a fine or
a coarse movement.

Results pane The results pane displays the mask test result, number of
mask hits, Vswing value, and the Tbit value. The Data
Jitter and the Hist Pk-Pk values are also shown near the
results pane.

Half Screen Click Half Screen to show the plot in half screen.
Full Screen Click Full Screen to maximize the plot to full screen.
xxx

Click Hist to draw the histogram on the eye diagram plot.

Click Hist Limits to draw a histogram box.

Double-click the buttons next to the Ymax, Ymin, Xmin, and Xmax labels to type the X and Y
histogram limits.

The results pane displays the mask test result, number of mask hits, Vswing value, and the Tbit
value. The Data Jitter and the Hist Pk-Pk values are also shown near the results pane. If there is no
value for data jitter, then it implies the absence of data points in the histogram window. In this case,
increase the record length value and run the test again.
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Result name Description
Mask Test View the mask test result as either Pass, Conditional

Pass, or Fail.
Mask Hits View the number of mask hits.
Vswing View the voltage swing of the signal.
Tbit View the time period of each bit.
xxx

12.Click Half Screen to view the eye diagram plot in half screen. You can also view both the result
summary of the test and the report configuration in the result pane as shown in the following figure.
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The result pane comprises both the result summary pane and the report configuration pane.

Result Summary pane

The result summary pane displays the test results.
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This icon indicates that the test has passed.

This icon indicates that the test has failed.

This icon indicates that the test could not be run.

Options Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Data Lane Select the data lane pair for which to display the

corresponding eye diagram plot.
View Jitter Plot Click View Jitter Plot to view the jitter plot for the selected

test point for the eye diagram test.
View Eye Plot Click View Eye Plot to view the eye plot for the selected test

point for the eye diagram test.
Result Details Click Result Details to display the details of the result.
xxx

Report Configuration pane

You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
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Category Description
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column describes the HDMI standards

and test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Conditional Pass, Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the results of

Tbit, Vswing, and Margin. If the test could not be run, then
an error code appears.

Close Click Close to quit the Result Details dialog box.
View Eye Plot Click View Eye Plot to display the eye plot.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

14.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.
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The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X ) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
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xxx

Duty Cycle
This test allows you to confirm that the duty cycle of the differential TMDS clock does not exceed the
limits allowed by the specification.

You will need one supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Duty Cycle check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

TDSHT3 HDMI Compliance Test Software Online Help 155



How to ... Duty Cycle

4. In the input pane, you have the following option:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, and Ch4.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

7. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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8. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.

9. Click Run Test to run the test. The TDSHT3 HDMI Compliance Test Software sets up the oscilloscope
and the test runs, displaying a progress indicator.
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10.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.

Option Description
Test Name The Test Name box displays the test id, test name, and lane.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

11.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
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Category Description
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

12.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

lane.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, and Margin. If the test could not
be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx
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Rise Time
This test allows you to confirm that the rise times on the TMDS differential signals fall within the limits of
the specification.

You will need one supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Rise Time check box

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

160 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Rise Time

4. In the input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, and Not Conn.

Data0 Data0 indicates the source channel to which you will
connect the HDMI data0 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data1 Data1 indicates the source channel to which you will
connect the HDMI data1 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data2 Data2 indicates the source channel to which you will
connect the HDMI data2 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existding Value to use the previously calculated Tbit

value.
xxx

7. In the reference levels pane, you have the following options:
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Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.

High In the High box, enter the desired high reference voltage
value. The default value is 80 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

Low In the Low box, enter the desired low reference voltage
value. The default value is 20 percent.

xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.
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10.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.

11.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.
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Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

12.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the lower limit and upper

limit of the rise time test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, Vswing, Upper Margin, and Lower
Margin. If the test could not be run, then an error code
appears.

Close Click Close to quit the Result Details dialog box.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

14.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.
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The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
xxx

Fall Time
This test allows you to confirm that the fall times on the TMDS differential signals fall within the limits of
the specification.

You will need one supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.
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2. In the differential tests pane, select the Fall Time check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

4. In the input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, and Not Conn.

Data0 Data0 indicates the source channel to which you will
connect the HDMI data0 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.
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Configure parameter Description
Data1 Data1 indicates the source channel to which you will

connect the HDMI data1 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data2 Data2 indicates the source channel to which you will
connect the HDMI data2 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

7. In the reference levels pane, you have the following options:

Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.

High In the High box, enter the desired high reference voltage
value. The default value is 80 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

Low In the Low box, enter the desired low reference voltage
value. The default value is 20 percent.

xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.

10.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.
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11.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.

Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

12.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
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Category Description
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the lower limit and upper

limit of the fall time test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, Vswing, Upper Margin, and Lower
Margin. If the test could not be run, then an error code
appears.

Close Click Close to quit the Result Details dialog box.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

14.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.
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The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lane.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
xxx
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Clock Jitter
This test allows you to confirm that the TMDS clock does not carry excessive jitter.

You will need one supported oscilloscope, one differential probe, one DC power supply 3.3 V, one EDID
emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Clock Jitter check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the
general-purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the
factory defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.
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4. In the input pane, you have the following option:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, and Ref4.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
Record Length In the Rec Length box, enter the desired record length value

for the clock jitter tests.
xxx

6. In the CRU pane, you have the following option:

Configure parameter Description
CRU The CRU list allows you to configure the Clock Recovery

Unit. The available choices are PLL, Raw, and Ideal. The
default value is first order PLL and is used for compliance
testing. Raw and Ideal are used for analysis.

xxx

7. In the reference levels pane, you have the following options:

Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.

10.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.

11. If you have run the clock jitter test successfully, the software makes Result available automatically and
displays the clock jitter plot.

The clock jitter plot is as follows:
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NOTE. In the full screen mode, the histogram disappears if you click anywhere within the plot.

The name of the buttons available on the clock jitter plot and their descriptions are as follows:

Options Description
Save Image Click Save Image to save the clock jitter plot.
Zoom-In Click the Zoom-In icon to zoom the area of interest. You

can zoom up to five times the normal view. Either drag the
mouse or click to zoom in to define the area of interest.

Zoom-Out Click the Zoom-out icon to zoom out.
Reset Plot Click Reset Plot to reset the plot.
Hist Click Hist to draw the histogram.
Hist Limits Click Hist Limits to draw the histogram box.
Hist Save Click Hist Save to save the histogram.
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Options Description
Fix Scale Click Fix Scale to allow the user to type a new scale value.
Enter Scale Click Enter Scale to allow the user to type a new scale

value in the Vertical Scale box.
Results pane The results pane displays the result, Pk-Pk value, Vswing

value, and the Tbit value. The IT Pk-Pk and the Hist
Pk-Pk values are also shown near the results pane.

Half Screen Click Half Screen to show the plot in half screen.
Full Screen Click Full Screen to maximize the plot to full screen.
xxx

Click Hist to draw the histogram on the eye diagram plot.

Click Hist Limits to draw a histogram box.

Double-click the buttons next to the Ymax, Ymin, Xmin, and Xmax labels to type the X and Y
histogram limits.

The results pane displays the result, Pk-Pk value, Vswing value, and the Tbit value. The IT Pk-Pk
and the Hist Pk-Pk values are also shown near the results pane. If there is no value for IT Pk-Pk,
then it implies the absence of data points in the histogram window. In this case, increase the record
length value and run the test again.
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Result name Description
Result View the result of the test as Pass or Fail.
Pk-Pk View the Pk-Pk value.
Vswing View the voltage swing of the signal.
Tbit View the time period of each bit.
xxx

12.Click Half Screen to view the clock jitter plot in half screen. You can also view both the result
summary of the test and the report configuration in the result pane as shown in the following figure.

The result pane comprises both the result summary pane and the report configuration pane.

Result Summary pane

The result summary pane displays the test results.
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This icon indicates that the test has passed.

This icon indicates that the test has failed.

This icon indicates that the test could not be run.

Options Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status The status icons display the status of the test as Pass, Fail,

or Error.
View Jitter Plot Click View Jitter Plot to display the jitter plot. This option is

available if you have successfully run the clock jitter test.
Result Details Click Result Details to display the Result Details dialog

box that shows the details of the test results categorized
as Test Name, Spec Range, Meas Value, Result, and
Remarks/Comments.

xxx

Report Configuration pane

You can set the report details to identify and generate the report automatically. You can set a default
report file.
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In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column describes the HDMI standards

and test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
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Options Description
Remarks/Comments The Remarks/Comments column displays the results of

Tbit, Vswing, and Margin. If the test could not be run, then
an error code appears.

Close Click Close to quit the Result Details dialog box.
View Jitter Plot Click View Jitter Plot to display the jitter plot. This option is

available if you have successfully run the clock jitter test.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

14.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.

The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X
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Options Description
Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X ) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
xxx

Inter-Pair Skew
This test allows you to confirm that any skew between the differential pairs in the TMDS portion of the
HDMI link does not exceed the limits in the specification.

You will need one supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

NOTE. Deskew is recommended before you conduct any skew test.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, select the Inter-Pair Skew check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

For 2–Channel setup, the configuration is as follows:
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Remove the clock signal connection and connect the data pair between which you want to calculate
the skew.

4. In the input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, and Ch4.

Data0 Data0 indicates the source channel to which you will
connect the HDMI data0 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data1 Data1 indicates the source channel to which you will
connect the HDMI data1 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data2 Data2 indicates the source channel to which you will
connect the HDMI data2 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

xxx

5. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

6. In the reference levels pane, you have the following options:
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Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

xxx

7. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

8. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and
check your configuration and connections. The waveform shown here is for the re-calculate Tbit
option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to continue to
run the test. Go to step 10.
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9. If you have selected existing Tbit value, then click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

10.Click Run Test to run the test. The TDSHT3 HDMI Compliance Test Software sets up the oscilloscope
and the test runs, displaying a progress indicator.

11.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.
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Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

12.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, Vswing, and Margin. If the test
could not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

o

Differential Tests Select All
This option enables you to run the eye diagram, duty cycle, rise time, fall time, and clock jitter test
simultaneously.

You will need one supported oscilloscope, two/four differential probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the differential tests pane, click Select All.

188 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Differential Tests Select All

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

For 2–Channel setup, the configuration is as follows:
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Remove the clock signal connection and connect the data pair between which you want to calculate
the skew.

4. In the input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, and Ch4.

Data0 Data0 indicates the source channel to which you will
connect the HDMI data0 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data1 Data1 indicates the source channel to which you will
connect the HDMI data1 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data2 Data2 indicates the source channel to which you will
connect the HDMI data2 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

xxx

5. In the horiz/acq pane, you have the following options:

Configure parameter Description
# of Acqs The # of Acqs box displays the number of acquisitions that

are required for the test. The default value is 10k.
Record Length In the Rec Length box, enter the desired record length value

for all the selected tests.
xxx

6. In the CRU pane, you have the following option:

Configure parameter Description
CRU The CRU list allows you to configure the Clock Recovery

Unit. The available choices are PLL, Raw, and Ideal. The
default value is first order PLL and is used for compliance
testing. Raw and Ideal are used for analysis.

Define The Define is available only when PLL is selected.
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xxx

7. In the reference levels pane, you have the following options:

Configure parameter Description
Units The Units list allows you to set the reference level units to

either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.
The hysteresis range is between 2 percent and 10 percent.

High The High box displays the high reference voltage value.
The default value is 80 percent.

Mid In the Mid box, enter the desired mid reference voltage
value. The default value is 50 percent.

Low The Low box displays the low reference voltage value. The
default value is 20 percent.

xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and check
your configuration and connections.
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10.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.

11. If you have run the tests successfully, the software makes Result available automatically and displays
the eye diagram plot and the clock jitter plot. For more information on the plots, refer to the section on
the eye diagram and the clock jitter tests. You can also view both the result summary of the test and the
report configuration in the result pane as shown in the following figure:
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Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
View Jitter Plot Click View Jitter Plot to view the jitter plot for the clock jitter

test.
View Eye Plot Click View Eye Plot to view the eye plot for the eye diagram

test.
Result Details Click Result Details to display the details of the result.
xxx

12.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.
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Category Description
Save As Click Save As to save the generated reports. The Save

File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column describes the HDMI standards

and test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the results of

Tbit, Vswing, and Margin. If the test could not be run, then
an error code appears.

Close Click Close to quit the Result Details dialog box.
View Jitter Plot Click View Jitter Plot to display the jitter plot for the clock

jitter test.
View Eye Plot Click View Eye Plot to display the eye plot for the eye

diagram test.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

14.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.

194 TDSHT3 HDMI Compliance Test Software Online Help



How to ... Differential Tests Select All

The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
xxx
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NOTE. Perform similar steps as mentioned in this procedure to test Single-Ended Select All.

Intra-Pair Skew (Source)
This test allows you to confirm that any skew within any one differential pair in the TMDS portion of the
HDMI link does not exceed the limits in the specification.

You will need one supported oscilloscope, two single-ended probes, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

Deskew is recommended before you conduct any skew test.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Intra-Pair Skew check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.
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4. In the input pane, you have the following options:

Configure parameter Description
Input1 indicates the source channel to which you will connect the HDMI input. The
available choices are Clock, Data0, Data1, and Data2.

Input+ Input+ indicates the source channel to which you will connect the positive input.
The available choices are Ch1, Ch2, Ch3, and Ch4.

Input1

Input– Input– indicates the source channel to which you will connect the negative input.
The available choices are Ch1, Ch2, Ch3, and Ch4.
Input2 indicates the source channel to which you will connect the HDMI input. The
available choices are Clock, Data0, Data1, Data2, and Not Conn.

Input+ Input+ indicates the source channel to which you will connect the positive input.
The available choices are Ch1, Ch2, Ch3, and Ch4.

Input2

Input– Input– indicates the source channel to which you will connect the negative input.
The available choices are Ch1, Ch2, Ch3, and Ch4.

xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

7. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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8. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and
check your configuration and connections. The waveform shown here is for the re-calculate Tbit
option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to continue to
run the test. Go to step 10.
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9. If you have selected existing Tbit value, then click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

10.Click Run Test to run the test. The TDSHT3 HDMI Compliance Test Software sets up the oscilloscope
and the test runs, displaying a progress indicator.

11.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.

Options Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

12.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:
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Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

13.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, Vswing, and Margin. If the test
could not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx
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Low Amplitude +
This test allows you to confirm that DC voltage levels on the HDMI link are within specified limits
for each TMDS signal.

You will need one supported oscilloscope, one single-ended probe, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Low Amplitude + check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.
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4. In the input pane, you have the following options:

Configure parameter Description
Input1 Input1 indicates the source channel to which you will connect the HDMI input.

The available choices are Ch1, Ch2, Ch3, and Ch4.
Input+ Input+ indicates the source channel to which you will connect the positive input.

The available choices are Ch1, Ch2, Ch3, and Ch4.
Input2 Input2 indicates the source channel to which you will connect the HDMI input.

The available choices are Ch1, Ch2, Ch3, Ch4, and Not Conn.
Input+ Input+ indicates the source channel to which you will connect the positive input.

The available choices are Ch1, Ch2, Ch3, and Ch4.
xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

7. In the voltage pane, you have the following option:

Configure parameter Description
AVcc In the AVcc box, enter the desired voltage value. The

default value is 3.3 V.
xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and
check your configuration and connections. The waveform shown here is for the re-calculate Tbit
option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to continue to
run the test. Go to step 11.
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10.If you have selected existing Tbit value, then click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

11.Click Run Test to run the test. The TDSHT3 HDMI Compliance Test Software sets up the oscilloscope
and the test runs, displaying a progress indicator.

12.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.

Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

13.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:
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Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

14.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value in

volts.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
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Options Description
Remarks/Comments The Remarks/Comments column displays the relevant

details of Tbit, Vswing, Upper Margin, and Lower Margin. If
the test could not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

Low Amplitude -
This test allows you to confirm that DC voltage levels on the HDMI link are within specified limits
for each TMDS signal.

You will need one supported oscilloscope, one single-ended probe, one DC power supply 3.3 V, one
EDID emulator, and one TPA-P fixture.

NOTE. For the DPO/DSA70000 series oscilloscopes with P7313 SMA probes and Efficere fixtures, you
have the option to set the probe control voltage to internal from the Preferences menu. If this option is
selected, an external power supply is not required.

1. On the menu bar, click Tests > Select > Source.

2. In the single-ended tests pane, select the Low Amplitude - check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.
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4. In the input pane, you have the following options:

Configure parameter Description
Input1 Input1 indicates the source channel to which you will connect the HDMI input. The

available choices are Ch1, Ch2, Ch3, and Ch4.
Input– Input– indicates the source channel to which you will connect the negative input.

The available choices are Ch1, Ch2, Ch3, and Ch4.
Input2 Input2 indicates the source channel to which you will connect the HDMI input. The

available choices are Ch1, Ch2, Ch3, Ch4, and Not Conn.
Input– Input– indicates the source channel to which you will connect the input. The

available choices are Ch1, Ch2, Ch3, Ch4, and Not Conn.
xxx

5. In the horiz/acq pane, you have the following option:

Configure parameter Description
# of Acqs In the # of Acqs box, enter the desired number of

acquisitions that are required for the test. The default value
is 10 K.

xxx

6. In the tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

7. In the voltage pane, you have the following option:
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Configure parameter Description
AVcc In the AVcc box, enter the desired voltage value. The

default value is 3.3 V.
xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

9. Ensure that your signal in the oscilloscope display is similar to the sample signal. Click View
Waveform to display a sample of the expected signal. If the displays are not similar, go back and
check your configuration and connections. The waveform shown here is for the re-calculate Tbit
option. Click Run Test to run the test. The Confirm dialog box appears. Click Continue to continue to
run the test. Go to step 11.
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10.If you have selected existing Tbit value, then click View Waveform to get a different waveform on
your display. Ensure that your signal in the oscilloscope display is similar to the sample signal.

11.Click Run Test to run the test. The TDSHT3 HDMI Compliance Test Software sets up the oscilloscope
and the test runs, displaying a progress indicator.

12.The software makes Result available automatically and displays the result summary. You can also view
the report configuration details in the result pane.
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Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

13.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

14.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value in

volts.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details of Tbit, Vswing, Upper Margin, and Lower Margin. If
the test could not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

Min/Max-Diff Swing Tolerance
This test allows you to confirm that the Sink correctly supports TMDS differential voltages at minimum
levels.

You will need one supported oscilloscope, one digital timing generator (DTG), one differential probe, one
DC power supply, eight SMA cables, one GPIB controller, and one TPA-P-TDR fixture.

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Min/Max-Diff Swing Tolerance check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

4. In the Input pane, you have the following option:

Configure parameter Description
Input Input indicates the channel to which you will connect the

HDMI input signal. The available choices are Ch1, Ch2,
Ch3, and Ch4.

xxx

5. In the DTG Method pane, you have the following option:

Configure parameter Description
Select From List Select the DTG pattern file from the drop-down list.
Outputs Click outputs to display a dialog box where you can set

unique Clock, Data0, Data1, and Data2 outputs.
xxx

6. The DTG Outputs dialog box has the following options:
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Configure parameter Description
Clock The Clock list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data0 The Data0 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data1 The Data1 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data2 The Data2 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
xxx

NOTE. You cannot exit the dialog box unless each of the clock and data selections are unique.

7. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

8. To configure and test the GPIB connection to the DTG, click Signal Sources. The Signal Sources
Setup dialog box appears.
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9. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here for more
information.

10.To test both the connection and the DTG GPIB configuration, click Test Conn.

11.Because no signal is connected to the oscilloscope, you cannot view the waveform for the min-diff
sensitivity test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 µsec on your GPIB
board configuration. For more details, click here.

12.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and conducts the test. Follow the instructions in the dialog box. Depending on your
answer, a series of dialog boxes may prompt you for your input.

13.If you successfully run the test, the software makes Result available automatically and displays the
result summary. You can also view the report configuration details in the result pane.
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Option Description
Test Name The Test Name box displays the test id, test name, VIcm,

and lane.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

14.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

15.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name,

VIcm, and lane.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value in mV.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Vswing, and Margin. If the test could
not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

Jitter Tolerance
This test allows you to confirm that the maximum allowed TMDS clock jitter is supported by the Sink DUT.

The signal degradation of typical passive copper cables increases with the frequency and the length of the
cable. To recover data from such cables, the TDSHT3 applies the reference cable equalizer (as specified in
the HDMI specifications 1.3) automatically to the jitter tolerance measurement when the clock frequency
is more than 165 MHz.

To use the DTG test method, you will need one supported oscilloscope, two differential probes, one
digital timing generator (DTG), one arbitrary waveform generator (AWG), one DC power supply, 12
SMA cables, two bias-tees, one cable emulator, one GPIB controller, one TPA-R-DI, one TPA-R-TDR,
and TTC modules.

1. On the menu bar, click Tests > Select > Sink.

2. In the differential tests pane, select the Jitter Tolerance check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

4. In the Input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the channel to which you will connect the

HDMI clock signal. The available choices are Ch1, Ch2,
Ch3, and Ch4.

Data Data indicates the channel to which you will connect the
HDMI data signal. The available choices are Ch1, Ch2,
Ch3, and Ch4.

xxx

5. In the Setup pane, set the following options:
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Configure parameter Description
Frequency Pair In the Frequency Pair list, click the desired value for the

jitter tolerance tests. The available choices are D, Ck:
500 KHz, 10 MHz and D, Ck: 1 MHz, 7 MHz, and Both. If
you select Both, the test is run for both the frequency pairs.

DUT Freq (MHz) In the DUT Freq (MHz) list, select the frequency value for
the DUT. The available choices depend upon the selected
test method.

xxx

6. In the DTG Method pane, you have the following options:

Configure parameter Description
Jitter Insertion
Composite AWG Select AWG to insert composite jitter using an AWG.

NOTE. In composite jitter, both clock and data
jitter frequency components are added to the
clock signal.

Composite AFG Select AFG to insert composite jitter using an AFG.

NOTE. In composite jitter, both clock and data
jitter frequency components are added to the
clock signal.

Separate AWG Select AWG to insert separate jitter.

NOTE. In separate jitter insertion, clock jitter is
added to the clock signal and data jitter is added
to the data signal.

Jitter Amplitude
Clock Set the amplitude of the clock jitter. By default the value is

set to the value specified in the HDMI standards.
The minimum and maximum value of clock are 150 mTbit
and 500 mTbit respectively.

Data Set the amplitude of the data jitter. By default the value is
set to the value specified in the HDMI standards.
The minimum and maximum value of data are 150 mTbit
and 500 mTbit respectively.

Pattern List Select the DTG pattern file from the drop-down list for the
selected DUT frequency.

DTG
Outputs Click outputs to display a dialog box where you can set

unique Clock, Data0, Data1, and Data2 outputs.
xxx

7. The DTG Outputs dialog box for DTG method has the following options:
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Configure parameter Description
Clock The Clock list allows you to configure the clock output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data0 The Data0 list allows you to configure the Data0 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data1 The Data1 list allows you to configure the Data1 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data2 The Data2 list allows you to configure the Data2 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
xxx

8. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

9. To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.
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10.In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here for more
information.

11.To test the connection and the GPIB configuration, click Test Conn.

12.Because no signal is connected to the oscilloscope, you cannot view the waveform for the jitter
tolerance test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 µsec on your GPIB
board configuration. For more details, click here.

13.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and conducts the test.

14.Follow the instructions in the Sink Jitter Tolerance dialog box. Click OK. The Connect Sink Device
dialog box for low frequency appears as follows.
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The Connect Sink Device dialog box for high frequency appears as follows.

15.Follow the instructions in the Connect Sink Device dialog box. Click OK. The test runs, displaying a
progress indicator. The Confirm Sink Device Support dialog box appears.

16.Follow the instructions in the dialog box. Depending on your answer, a series of dialog boxes may
prompt you for your input.

17.If you successfully run the test, the software calculates the jitter values and displays the results. The
software makes Result available automatically and displays the result summary. You can also view the
report configuration details in the result pane.
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Option Description
Test Name The Test Name box displays the test id, test name, and

selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx

18.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.
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Category Description
Auto Increment Select the Auto Increment check box to generate a new

report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

19.In the result summary pane, click Result Details to display the details of the result.

Options Description
Test Name The Test Name column displays the test id, test name, and

selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value in mV.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Vswing, and Margin. If the test could
not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

Intra-Pair Skew (Sink)
This test allows you to confirm that the maximum allowed timing skew within each TMDS pair is
supported by the Sink DUT.
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To use the DTG test method, you will need one supported oscilloscope, one differential probe, one cable
emulator, one TPA-P-DI fixture, one digital timing generator (DTG), one DC power supply, eight SMA
cables, one GPIB controller, and one TPA-P-TDR fixture.

1. On the menu bar, click Tests > Select > Sink.

2. In the single-ended tests pane, select the Intra-Pair Skew check box.

3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

NOTE. The default configuration is to introduce skew on a single channel (Clock). If you want to calculate
the intra-pair skew for all channels, then connect the desired channel to A1 and A2. For example, to
calculate the intra-pair skew of Data0, assign A1 to Data0 and B1 to Clock. Make the appropriate
changes in the test connections.

4. In the Input pane, you have the following option:
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Configure parameter Description
Clock Clock indicates the channel to which you will connect the

HDMI clock signal. The available choices are Ch1, Ch2,
Ch3, and Ch4.

xxx

5. In the Tbit pane, you have the following options:

Configure parameter Description
# of Avgs In the # of Avgs box, enter the desired number of periods

that are considered to calculate Tbit. The default value is
100.

Re-calculate Click Re-calculate to recalculate the Tbit value.
Existing Value Click Existing Value to use the previously calculated Tbit

value.
xxx

6. In the Skew Configuration pane, you have the following option:

Configure parameter Description
Skew on all channels Select the skew on all channels to set the skew on all the

channels. This way skew will be introduced on Clock, D0,
D1, and D2. All the four DTGM30 modules are required
for this option.
If this option is not selected, the skew is set on one channel.

xxx

NOTE. The four DTGM modules can be connected as follows: Clock +ve to A1 and Clock –ve to A2, D0
+ve to B1 and D0 –ve to B2, D1 +ve to C1 and D1 –ve to C2, D2 +ve to D1 and D2 –ve to D2.

7. In the DTG Method pane, you have the following options:

Configure parameter Description
Pattern List Select the DTG pattern file from the drop-down list.
Outputs Click outputs to display a dialog box where you can set

Clock, Data0, Data1, and Data2 outputs.
xxx

8. In the DTG Method pane, the Outputs dialog box has the following options:
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Configure parameter Description
Clock The Clock list allows you to configure the clock output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data0 The Data0 list allows you to configure the Data0 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data1 The Data1 list allows you to configure the Data1 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data2 The Data2 list allows you to configure the Data2 output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
xxx

NOTE. You cannot exit the dialog box unless each of the clock and data values are unique.

9. To connect the DUT, click Tests > Connect. Click here for information on how to make connections.

10.To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.
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11. In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here for more
information.

12.To test the connection and the GPIB configuration, click Test Conn.

13.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and conducts the test. Follow the instructions in the dialog box. Depending on your
answer, a series of dialog boxes may appear asking for your input.

14.If you successfully run the test, the software makes Result available automatically and displays the
result summary. You can also view the report configuration details in the result pane.

Options Description
Test Name The Test Name box displays the test id, test name, and

selected names.
Status Status indicates the status of the test as Pass, Fail, or Error.
Result Details Click Result Details to display the details of the result.
xxx
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15.You can set the report details to identify and generate the report automatically. You can set a default
report file.

In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

16.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name, and

selected names.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Tbit, Vswing, and Margin. If the test
could not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
xxx

Eye Diagram (Cable)
This test allows you to confirm that the Cable assembly outputs a compliant data eye. You can check the
input test signal at TP1 and verify the output of the cable for compliance at TP2.

The signal degradation of typical passive copper cables increases with the frequency and the length of the
cable. To recover data from such cables, the TDSHT3 applies the reference cable equalizer (as specified in
the HDMI specifications 1.3) automatically to the eye diagram measurement when the clock frequency is
more than 165 MHz.

You will need one supported oscilloscope, two/four differential probes, one digital timing generator
(DTG), one arbitrary function generators (AFG), one GPIB controller, one DC power supply 3.3 V, eight
SMA cables, one TPA-R-DI fixture, and one TPA-R-TDR fixture.

1. On the menu bar, click Tests > Select > Cable.

2. In the differential tests pane, select the Eye Diagram check box.
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3. To change the configuration settings, click Tests > Configure. For most tests, you can use the factory
default configuration. However, you can change the values by using the virtual keyboard or the general
purpose knob on the oscilloscope front panel. Using the File menu, you can also restore the factory
defaults or save and recall your own configuration settings. It is recommended that you save the
configuration settings before you choose to select Recall Default or close the application.

4. In the Input pane, you have the following options:

Configure parameter Description
Clock Clock indicates the source channel to which you will connect

the HDMI clock input lane. The available choices are Ch1,
Ch2, Ch3, and Ch4.

Data0 Data0 indicates the source channel to which you will
connect the HDMI data0 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data1 Data1 indicates the source channel to which you will
connect the HDMI data1 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

Data2 Data2 indicates the source channel to which you will
connect the HDMI data2 input lane. The available choices
are Ch1, Ch2, Ch3, Ch4, and Not Conn.

xxx

5. On the Setup tab, in the Horiz/Acq pane, you have the following options:
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Configure parameter Description
Rec Length In the Rec Length box, enter the desired record length value

for the eye tests.
CRU The CRU list allows you to configure the Clock Recovery

Unit. The available choices are PLL, Raw, and Ideal. The
default value is first order PLL and is used for compliance
testing. Raw and Ideal are used for analysis.

xxx

6. On the Setup tab, in the Test Points pane, you have the following options:

Configure parameter Description
TP1 TP1 represents the first test point. Feed the worst possible

compliant signal at TP1. By default, the TP1 check box is
selected.

TP2 TP2 represents the second test point. The worst possible
compliant signal fed at TP1 is transmitted through the cable.
The same signal is tested at TP2 with the TP2 specification.
By default, the TP2 check box is selected.

xxx

7. On the Setup tab, you also have the following options:

Configure parameter Description
Ref Level Units The Ref Level Units list allows you to set the reference level

units to either Per (%) or Abs.
Per (%) indicates that the reference levels are a percentage
of the Vswing value.
Abs indicates that the reference levels are absolute voltage
values.

Hysteresis In the Hysteresis box, enter the desired hysteresis percent
value. The default value is 10 percent.

Mid Ref In the Mid Ref box, enter the desired mid reference voltage
value. The default value is 50 percent.

xxx

8. On the DTG Method tab, you have the following options:
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Configure parameter Description
Pattern List Select the DTG pattern file from the drop-down list.
Outputs Click outputs to display a dialog box where you can set

Clock, Data0, Data1, and Data2 outputs.
Jitter Insertion
DTG (Internal) Select DTG to insert jitter using a DTG.
AFG Select AFG to insert jitter using an AFG.
xxx

9. In the DTG Outputs dialog box, you have the following options:

Configure parameter Description
Clock The Clock list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data 0 The Data 0 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data 1 The Data 1 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
Data 2 The Data 2 list allows you to configure the output. The

available choices are A1, A2, B1, B2, C1, C2, D1, and D2.
xxx

NOTE. You cannot exit the dialog box unless each of the clock and data values are unique.

10.On the Cable Equalizer Configuration tab, you have the following options:
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Configure options Description
Use internal coefficients Select the Use Internal coefficients check box to use

the internal coefficients that are already available (these
coefficients are in accordance with the CTS).

Use coefficients from a file Select the Use coefficients from a file check box to use the
coefficients from a file. You can browse the cable equalizer
file from the Cable Equalization Path option.

Do not apply equalizer for Clock and Data Select Do not apply equalizer for Clock and Data check box
if you do not want to apply cable equalization.

xxx

11.On the Rise Time Filter Configuration tab, you have the following options:

Configure options Description
Use internal coefficients Select the Use Internal coefficients check box to use

the internal coefficients that are already available (these
coefficients are in accordance with the CTS).

Use coefficients from a file Select the Use coefficients from a file check box to use the
coefficients from a file. You can browse to the rise time filter
file from the Rise Time Filter Path.

Do not apply equalizer for Clock and Data Select Do not apply rise time filter for Clock and Data check
box if you do not want to filter.

xxx

12.To connect the DUT, click Tests > Connect. Click here for information on how to make connections.
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13.To configure and test the GPIB connection, click Signal Sources. The Signal Sources Setup dialog
box appears.

14.In the select pane, click GPIB. Configure the appropriate GPIB board number. Click here for more
information.

15.To test the connection and the GPIB configuration, click Test Conn.

16.Because no signal is connected to the oscilloscope, you cannot view the waveform for the eye diagram
test.

NOTE. To run the test successfully, ensure that the Bus Timing parameter is set to 2 µsec on your GPIB
board configuration. For more details, click here.

17.Click Run Test to perform the test. The TDSHT3 HDMI Compliance Test Software sets up the
oscilloscope and the test runs, displaying a progress indicator.
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18.In the GPIB mode, the application automatically adjusts the jitter amplitude on DTG and displays the
measured jitter value. Follow the on-screen instructions to enable you to re-adjust the jitter value. The
software creates a worst eye and asks you to verify the worst eye. Follow the on-screen instructions.
Depending on your answer, a series of dialog boxes may prompt you for your input.

19.If you have run the test successfully, the software makes Result available automatically and displays
the eye diagram plot and the clock jitter plot for both TP1 and TP2. For more information on the
plots, refer the section on the source eye diagram test and the source clock jitter test. You can also
view both the result summary of the test and the report configuration in the result pane as shown in
the following figure:

Options Description
Test Name The Test Name box displays the test id, test name, test

point, and selected lanes.
Status Status indicates the status of the test as Pass, Fail, or Error.
Test Point You can check the input test signal at TP1 and verify the

output of the cable for compliance at TP2. From the Test
Point list, select either TP1 or TP2 to view the respective
details.

Data Lane Select the data lane pair for which to display the
corresponding eye diagram plot.

NOTE. This option is applicable only for TP2.
View Eye Plot Click View Eye Plot to view the eye plot for the selected test

point and data lane for the eye diagram test.
Result Details Click Result Details to display the details of the result.
xxx

20.You can set the report details to identify and generate the report automatically. You can set a default
report file.
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In the report configuration pane, you can configure the following parameters:

Category Description
Device Details The Device Details box allows you to specify the

device-related information on which the test is conducted.
Resolution The Resolution box allows you to specify the resolution on

which the test is conducted.
Refresh Rate The Refresh Rate box allows you to specify the refresh rate

at which the test is conducted.
Report File The Report File box allows you to specify the path and the

file where the generated report will be saved. However, a
default file name and path already exists.

Auto Increment Select the Auto Increment check box to generate a new
report. Selecting this option does not overwrite the existing
report. However, it adds the date and time to the existing
file name.

Save As Click Save As to save the generated reports. The Save
File dialog box is displayed. You can enter a file name and
save the report.

Clear Report Click Clear Report to clear all the results and records of
the earlier tests.

xxx

21.In the result summary pane, click Result Details to display the details of the result.
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Options Description
Test Name The Test Name column displays the test id, test name, test

point, and selected lanes.
Spec Range The Spec Range column displays the HDMI standards and

test specifications limit for the test.
Meas Value The Meas Value column displays the measured value in mV.
Result The Result column displays the status of the test as Pass,

Fail, or Error.
Remarks/Comments The Remarks/Comments column displays the relevant

details, for example, Vswing, and Margin. If the test could
not be run, then an error code appears.

Close Click Close to quit the Result Details dialog box.
Test Point You can check the input test signal at TP1 and verify the

output of the cable for compliance at TP2. From the Test
Point list, select either TP1 or TP2 to view the respective
details.

Data Lane Select the data lane pair for which to display the
corresponding eye diagram plot.

NOTE. This option is applicable only for TP2.
View Eye Plot Click View Eye Plot to view the eye plot for for the selected

test point and data lane for the eye diagram test.
Result Statistics Click Result Statistics to display statistics based on the

tests.
xxx

22.In the Result Details dialog box, click Result Statistics to display statistics based on the tests.
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The software calculates statistics for each selected test, and logs the statistics on a cycle-by-cycle
basis in a large waveform. The standard statistics are for the Maximum, Minimum, Mean, Standard
Deviation, and Population.

Options Description
Test Name The Test Name column displays the test id, test name, test

point, and selected lanes.
Population The software calculates this statistic by using the following

equation:
Population (X) = N

Min The software calculates this statistic by using the following
equation:
Min (X) = Lowest value of X

Max The software calculates this statistic by using the following
equation:
Max (X) = Highest value of X

Mean The software calculates this statistic by using the following

equation:
Std Dev The software calculates this statis-

tic by using the following equation:

Pk-Pk The software calculates this statistic by using the following
equation:
Xppn = Max(X) – Min(X )

Close Click Close to quit the Result Statistics dialog box.
xxx
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Software CRU Technology
The HDMI specification mandates the Clock Recovery Unit (CRU) by using a Phase Locked Loop
(PLL) with first order transfer function characteristics, to test both the jitter and the eye diagram. A
PLL-based CRU implemented in hardware makes correlation of test results difficult due to differences in
vendor-specific implementations. Software PLL techniques can extract clock and timing data from a serial
data stream. The following method shows a practical and affordable way to satisfy the requirement:

PLL Characteristics

The diagram shows a simplified block diagram of generic phase-locked loop (PLL). A PLL consists of
the Phase Detector (PD), Low Pass Filter (LPF), Voltage Controlled Oscillator (VCO), and Frequency
Divider (FD).

The phase of the input signal is compared to the phase of FD output. The input of the FD is the output
of VCO, whose frequency is controlled by the LPF output. The LPF output is a filtered form of the PD
output. When the phase of FD output is leading compared to the input phase, the PD output changes to
decrease the VCO frequency. Thus, the FD output will lag. Due to the effect of this feedback mechanism,
the frequency of VCO is locked to N-times of the input frequency.
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The LPF restricts the quick variation of the incoming signal, so that high frequency changes in the input
phase are attenuated before they are transferred to consecutive functional blocks. Therefore, the VCO
output represents the average phase of input signal even if the input signal does not have the constant
phase rotation (frequency). Using this approach, the PLL circuitry recovers the clock information from
the modulated input signal.

The transfer function from the input phase to the output phase is represented by following equation:

where Kp and Kv are the sensitivity coefficients of PD and VCO respectively, and N is the division factor
of FD. H(s) is the transfer function of LPF in the frequency domain.

Assuming that N, Kp, and Kv are constant, the function G(s) can be simplified as follows:

Note that G(s) becomes the first order low-pass filter only when H(s) is constant, namely, when H(s) is
non-dependent on the frequency. This means that H(s) is not a low- pass filter in this case. On the contrary,
it is well known that the PLL is not stable without a low-pass filter in place of H(s). Therefore, the first
order transfer function that is required by CRU for HDMI may not be realized by the PLL circuitry as
shown in the earlier PLL Functional Block diagram.

Conventional Method
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The diagram shows a simple PLL design for CRU, measuring both the clock jitter and eye diagram within
a digital oscilloscope. The input signal is first converted to digital information with an A/D converter. The
phase of the input signal is extracted by finding the rising (or falling) edges of the digitized signal. A digital
simulation of an actual hardware PLL circuit may be realized because the input and output signals exist as
just digital information. In this case, the voltage values at several points in the PLL circuit are expressed in
the time domain, and are repetitively calculated to derive their time variation. The time interval of the
calculation must be sufficiently small to retain the high precision of the simulation. Hence, it requires
significant digital processing capability to simulate actual PLL within a reasonable amount of time.

In this method, the phase transfer function of the PLL is determined by the characteristics of the simulated
components. As long as the simulation observes the laws of physics, the resultant transfer function
does not differ from that of the actual hardware PLL circuit. Given the time to process the data in the
simulation, using this method is not advisable. Hence, the first order transfer function to be realized by
this method may not be useful either.

Another method to simulate a PLL in software is to use its time domain transfer function from the input
phase error to output timing information. The impulse response is used as the time domain transfer
function. In this case, given the input signal X(t), the integral operation shown next gives the output
signal Y(t).

where G(t ) is the time domain representation of G(s) mentioned in the previous section. This is called a
convolution integral. In this case, the input signal is represented as discrete-time samples. The integration
shown earlier should also be performed in discrete fashion as follows:

There are two disadvantages in the time domain convolution method. One is that it still requires a huge
number of multiplications and additions to calculate the values of all time points, as easily seen from
the form of the equation above. Another is that it is not always practical to express the time domain
transfer function as an explicit mathematical representation. In many cases, the human interpretation of
the transfer function is made in frequency domain. Some means of conversion is required to derive the
time domain response from the frequency domain characteristics. This requirement will complicate the
design of the user interface.

It is important to mention that the first order transfer function characteristics can be realized by this
convolution method, even though it has the difficulties described earlier. This method is inherently stable
as far as an appropriate impulse response is adopted, because it does not include a feedback loop.
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Proposed Method

The PLL circuitry acts as a low-pass filter for incoming time information. In the frequency domain,
the filter function is simply realized by multiplying of the frequency response coefficients to the input
spectrum. The convolution integral in the time domain is equivalent to simple multiplication between
frequency-domain functions derived by the Fourier Transform. If the time information and the PLL
characteristics are transformed to frequency domain, the PLL processing becomes much easier than in
the time domain.

As seen in this equation, the calculation becomes one multiplication (though between complex numbers)
per sample point. Hence, the demand for digital processing performance is very low.

After the filter function is performed, the time information of the output signal may be derived with
inverse transformation. Using an FFT algorithm, the forward and inverse transformation can be executed
in relatively short time compared to simulation in time domain. Thus, the total time to calculate the
recovered clock can be significantly reduced.

Jitter Test
The jitter of the incoming clock signal is measured by statistically analyzing the time difference between
the incoming and recovered clocks. The timing information of both signals is already retained in digital
form, so the jitter calculation is simple and straightforward. Usually, the peak-to-peak jitter value and the
standard deviation ( RMS) jitter value are used for evaluating the signal quality.
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Appropriate sample points should be chosen to measure the jitter for specific cases such as the
clock-to-data jitter at the first bit. Such a requirement is addressed by specifying a rectangular area with
time range of [–T..+T] and voltage range of [–V..+V].

To obtain an accurate test, a large number of samples are required. As the earlier area restriction reduces
the number of measured samples, the capability to process more and more samples is desired. Using
the proposed method, it becomes realistic to gather a huge amount of statistical information for a more
precise test.

Eye Diagram
An eye diagram is the incoming data waveform repeatedly drawn with the recovered clock used as the
time reference. The recovered clock is represented as time information. Hence, it may be used to derive
the position where the input data waveform should be drawn. The resulting diagram will precisely indicate
the true marginal area with which the reliability of data transmission is determined.

The vertical coordinate to draw the incoming waveform is determined by using the data value itself.
Determine the horizontal coordinate (x) by the following equation:

where Tn is the time of incoming waveform, and Tref is the time of the reference signal (the recovered
clock signal).
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Eye Diagram
This sequence explains the actions that the software takes while it performs an eye diagram test. For the
procedure on how to make this test, see eye diagram test procedure.

1. Connect TPA-P-DI to the Source DUT HDMI output connector.

2. Connect the differential probes to TMDS Clock and configure as trigger.

3. Connect the second differential probe to TMDS Data.

4. Configure the Source DUT to output the first supported video format.

5. Set up the oscilloscope as follows:

Set the memory length to at least 25 M points.

Set the single-shot trigger at the rising edge of TMDS Clock (50 percent).

Set the sample rate to ≥ 10 GS/s based on the oscilloscope.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.

6. Capture the waveforms on the oscilloscope.

NOTE. Do not transfer the waveforms.

7. Perform software clock recovery as follows:

Find VH and VL of both clock and data.

Find 50 percent reference level of the clock.

Calculate the Software CRU filter as follows.

H(s) = 1/(1+sτ), where τ = 40 nsec.

Pass the TIE values through the filter (FFT and IFFT) H(s) = 1/(1+sτ), where τ = 40 nsec .

Reconstruct the clock, and then create a bit clock (x10 clock) by using even up sampling.

8. Draw the eye diagram.

x10 clock is used for slicing.

Draw the eye diagram with ½ UI+UI+½ UI method. This ensures that all UIs are overlapped.

9. Create eye mask.

Calculate VSWING by using VH and VL of the data.

Construct the mask co-ordinate by using TBIT and VSWING.

10.Position the mask in such a way that one of its left corners just touches the waveform.
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11. If any other part of the waveform either touches or crosses the data eye, then it implies FAIL.

12.Calculate the data jitter by using the histogram technique. The histogram co-ordinates are VC+/-5 mV.

13.If data jitter is more than (0.3*TBIT), then it implies FAIL.

14.Repeat the test for all the remaining TMDS_DATA pairs.

15.Repeat the test for all supported pixel clock rates. Only one video format is required per pixel clock rate.

Duty Cycle
This sequence explains the actions that the software takes while it performs a duty cycle test. For the
procedure on how to make this test, see duty cycle test procedure.

1. Connect a TPA-P-DI adapter to the Source DUT HDMI output connector.

2. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

3. Connect a differential probe to the TMDS Clock.

4. Display the waveform of one clock period.

5. Set up the oscilloscope as follows:

Adjust the vertical scale to accommodate the waveform in six vertical divisions (Refer vertical
setting)

Trigger: Edge trigger

Acquire at least 10,000 waveforms in FastAcq

6. Find the minimum and maximum duty cycle by using the following method:

7. Compare with the limit value.

If minimum duty cycle is more than 40 percent, then it implies PASS.

If maximum duty cycle is less than 60 percent, then it implies PASS.
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Rise/Fall Time
This sequence explains the actions that the software takes while it performs a rise/fall time test. For the
procedure on how to make this test, see rise time test procedure and fall time test procedure.

1. Connect an TPA-P-DI adapter to the Source DUT HDMI output connector.

2. Connect the Power Supply to the TPA board.

3. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

4. Connect a differential probe to TMDS_DATA0 and configure as trigger.

5. Set the trigger position at the center of the screen.

6. Set up the oscilloscope as follows:

Calculate TBIT by using differential clock.

Set the vertical scale to accommodate the waveform in at least six divisions.

Set the horizontal scale to more than 2*TBIT.

If pulse width trigger is selected, Trigger with pulse width trigger with (4*TBIT) pulse or trigger
with edge trigger.

7. Accumulate at least 10,000 triggered waveforms by acquiring the waveform in FastAcq mode of
acquisition.

8. Calculate VSWING of the signal (VSWING = VH–VL), and then find the 20 percent and 80 percent of the level.

9. Measure the rise time and fall time.

Enable the oscilloscope rise time measurement. Set the reference level to 20 percent and 80 percent.

Acquire at least 10 K waveforms (RUN and STOP).

Calculate the rise time.

Set the trigger to negative pulse.

Enable the oscilloscope rise time measurement.

Acquire at least 10 K waveforms (RUN and STOP).

Calculate the fall time.

10.Compare with the limit.

If TRISE is less than 75 ps or TRISE is more than (0.4*TBIT), then it implies FAIL.

If TFALL is less than 75 ps or TFALL is more than (0.4*TBIT), then it implies FAIL.

11.Repeat the test for all the remaining TMDS clock and data pairs.
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Clock Jitter
This sequence explains the actions that the software takes while it performs a clock jitter test. For the
procedure on how to make this test, see clock jitter test procedure.

1. Connect TPA-P-DI to the Source DUT HDMI output connector.

2. Connect the differential probe to the TMDS Clock and configure as trigger.

3. Connect the second differential probe to TMDS_CLOCK.

4. Configure the Source DUT to output the required supported video format.

5. Set up the oscilloscope as follows:

Adjust the vertical scale to accommodate the waveform in six vertical divisions

Set the record length to 25 M

Set the sample rate to ≥ 10 GS/s based on the oscilloscope

Trigger with the rising edge of the clock (50 percent level)

6. Capture the waveforms on the oscilloscope.

NOTE. Do not transfer the waveforms.

7. Perform software clock recovery as follows:

Set the reference level to 50 percent of the clock and hysteresis to 10 percent of VSWING.

Calculate the Software CRU filter as follows.

H(s) = 1/(1+sτ), where τ = 40 nsec.

8. Draw the TMDS waveform with positive edge trigger.

9. Measure the clock jitter as follows:

Calculate VSWING by using VH and VL of the clock.

Calculate the center voltage as follows:

VC = ( VH+VL)/2

Draw the histogram at VC+ /-20 mV.

Calculate Pk-Pk jitter and ‘Interpolated’ Pk-pk jitter.

10.If clock jitter exceeds (0.25*TBIT), then it implies FAIL.
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Inter-Pair Skew
This sequence explains the actions that the software takes while it performs an inter-pair skew test. For the
procedure on how to make this test, see inter-pair skew test procedure.

1. Connect an TPA-P-DI adapter to the Source DUT HDMI output connector.

2. Connect the first differential probe to TMDS_DATA0.

3. Connect the second differential probe to TMDS_DATA1.

4. Configure the Source DUT to output a video format with the required supported pixel clock frequency.

5. Set up the oscilloscope and acquire the waveform.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.

Calculate TBIT by using differential clock

Set the sample rate to ≥ 10 GS/s based on the oscilloscope

Set the bit rate based on the TBIT value

Acquire the waveform in real-time single shot

6. Calculate the inter-pair skew as follows:

Find the CTL pattern in Data<X>

Find the CTL pattern in Data<Y>

Find the skew between the two channels in each transition

Calculate the average skew

7. If TSKEW is greater than (0.2*TPIXEL), then it implies FAIL.

8. Repeat the test for the remaining combinations of TMDS pairs.

Intra-Pair Skew
This sequence explains the actions that the software takes while it performs an intra-pair skew test. For the
procedure on how to make this test, see intra-pair skew test procedure.

1. Connect an TPA-P-SE adapter to the Source DUT HDMI output connector.

2. Connect the first single-ended probe to TMDS_DATA0+.

3. Connect the second single-ended probe to TMDS_DATA0-.

4. Configure the Source DUT to output a video format with the highest supported pixel clock frequency.
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5. Set up the oscilloscope as follows:

Calculate TBIT by using differential clock.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.

Set the horizontal scale to (2*TBIT).

Trigger with edge trigger of Data+ (Rising edge with 50 percent level).

6. Display the waveform of TMDS_DATA0+ and DATA0-. Accumulate at least 10,000 triggers by
acquiring the waveform in FastAcq mode.

7. Determine the most common TMDS_DATA0- 50 percent point by using the histogram method.

8. Measure skew from most common TMDS_DATA0+ point to 50 percent point of first edge of
TMDS_DATA0-.

9. If skew is greater than (0.15*TBIT), then it implies FAIL.

10.Repeat the test for all the remaining TMDS differential pairs.

Min/Max-Diff Swing Tolerance
This sequence explains the actions that the software takes while it performs a min /max-diff swing tolerance
test. For the procedure on how to make this test, refer min/ max-diff swing tolerance test procedure.

1. Configure the DTG to output any sink-supported video format.

Load the pattern that contains repeating RGB gray ramp 0, 1, 2…254, 255, 0, 1, 2… during each
video period.

Map all the logical channels to physical channels.

Run the DTG.

Enable all the output channels.

2. Search for and record the minimum differential swing voltage that the Sink DUT supports without error
at VICM = 2.9 V (Frequency > 165 MHz) and 3.0 V (Frequency < 165 MHz).

Set VICM1 = 3.0\2.9 V.

Set VDIFF = 170 mV on all TMDS differential pairs. (Note that “Amplitude and Offset” mode in the
DTG “Level” window should be chosen. In this mode, “Amplitude” should be set to 0.085 Vpp to
correspond to a 170 mV differential swing.)

If the test passes at 170 mV, reduce VDIFF in 10 mV steps (corresponding to 0.01 Vpp steps in the
“Amplitude” setting) on all pairs until the Sink DUT outputs errors or VDIFF of 90 mV is reached.

If the test fails at 170 mV, increase VDIFF in 10 mV steps on all pairs until the Sink DUT outputs
pass or VDIFF of 250 mV is reached.

Record VDIFF {minimum} at first voltage level where no error appears.

3. Repeat the test for VICM2 = 3.3 V.
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4. Set VDIFF = 1.2 V on all TMDS differential pairs. (Note that “Amplitude and Offset” mode in the DTG
“Level” window should be chosen. In this mode, “Amplitude” should be set to 0.6 Vpp to correspond
to a 1.2 V differential swing.)

5. Verify that the DUT continues to support the signal without errors.

6. If DUT fails to support the signal, then it implies FAIL.

Jitter Tolerance
This sequence explains the actions that the software takes while it performs a jitter tolerance test. For the
procedure on how to make this test, refer jitter tolerance test procedure.

1. Operate the Sink DUT to support the HDMI input signal.

2. Configure the DTG as follows:

Load the appropriate pattern in the DTG

No jitter on any output

Set the signal outputs to 3.0 V average

3. Configure the AWG as follows:

Under “Vertical” menu, set the following:

Filter-through

Amplitude

Offset = 0 V

Marker 1 = 0.00 V to 1.00 V

Marker 2 = 0.00 V to 2.00 V

No jitter on output initially, with ability to add two simultaneous jitter components.

4. Connect the test fixture to the oscilloscope for jitter calibration. The oscilloscope calculates data and
clock jitter inserted due to the cables and the test fixtures along with the known amount of jitter.

5. Use the appropriate TTC module based on the recommended resolution.

6. Measure jitter tolerance while verifying adequate support by sink.

For each of the two test cases:

D_JITTER = 500 kHz, C_JITTER = 10 MHz

D_JITTER = 1 MHz, C_JITTER = 7 MHz

7. Increase the skew (Differential timing offset) in steps of 0.1 Tbit from 0.0 Tbit to 1.0 Tbit. The test fails
if the sink outputs errors at any point of time.

TDSHT3 HDMI Compliance Test Software Online Help 251



Test Methods Intra-Pair Skew

Intra-Pair Skew
This sequence explains the actions that the software takes while it performs an intra-pair skew test. For the
procedure on how to make this test, refer intra-pair skew test procedure.

1. Configure the DTG to output any sink-supported video format that uses the maximum sink-supported
pixel clock frequency. If multiple formats are available, a native format is preferred.

2. Calculate Tbit by using the differential clock.

3. For each of the TMDS clock and data pairs that act as the tested pair:

Set the delay for all outputs to 0 nS . Disable “Differential Timing Offset” if it is previously enabled.

Move the TMDS “+” signal of the tested pair to DTG output module A, 1+.

Move the TMDS “–” signal of the tested pair to DTG output module A, 2+.

Change the DTG configuration to output the pattern for the tested TMDS channel on module A, 1.

4. When Skew on all four channels option is selected, the skew on all the four channels will be calculated
based on the following conditions:

All four modules of the DTG must be DTGM30 modules. The test checks for the modules and
throws an error if they are not from the DTGM30.

The configuration to run the test are A1-Clock, B1-Data 0, C1- Data 1, and D1- Data 2. If the
test fails on any of the channels the skew will be inserted individually on the channels to find
the channel that has failed the test.

5. In the DTG “Timing”, set the tested channel (connected to 1A1) and enable “Differential Timing
Offset.”

6. Set the delay value in the differential timing offset to approximately (0.1*TBIT). This corresponds to the
initial intra-pair skew value.

7. Increase the skew (Differential Timing Offset) by steps of less than or equal to (0.1*TBIT), until the Sink
DUT outputs errors or until reaching either (0.6*TBIT) or 1 nsec.

8. If errors are seen on DUT, then:

Reduce the skew one step, so that the Sink DUT outputs no errors.

If intra-pair skew is less than (0.4*TBIT), then it implies FAIL.

Eye Diagram
This sequence explains the actions that the software takes while it performs an eye diagram test. For the
procedure on how to make this test, refer eye diagram test procedure.

Cable Equalizer: The signal degradation of typical passive copper cables increases with the frequency
and the length of the cable. To recover data from such cables, TDSHT3 applies the reference cable
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equalizer (as specified in the HDMI specification 1.3) automatically to the cable eye diagram measurement
when the clock frequency is more than 165 MHz.

1. Configure the DTG to output a video format corresponding to the specified bandwidth of the cable.
If no bandwidth is specified, then configure the DTG to output 1920 x 1080i @ 60 Hz (74.25 MHz
pixel clock).

Load the appropriate pattern file.

Set the logical channel to physical channel mapping.

Run the pattern.

Enable all the DTG output.

2. Configure the DTG to output worst-case eye as follows:

Adjust jitter on TMDS_CLOCK pair to output 0.4 nS at 500 KHz (worst jitter permitted at (TP1 =
0.3*TBIT) at 75 MHz).

Adjust the output swing voltage to 500 mV for every TMDS single-ended signal.

Using jitter/eye analyzer, measure the TMDS_CLOCK jitter and eye diagram of all the three
TMDS_DATA pairs.

Repeat and readjust as necessary to create the input worst-case eye diagram.

3. Set up the oscilloscope as follows:

Set the memory length to at least 25 M points.

Set the single-shot trigger at the rising edge of TMDS Clock (50 percent).

Set the sample rate to ≥ 10 GS/s based on the oscilloscope.

Adjust the vertical scale to accommodate the waveform in six vertical divisions.

4. Perform software clock recovery as follows:

Set the reference level to 50 percent of the clock and hysteresis to 10 percent of VSWING.

Calculate the Software CRU filter as follows.

H(s) = 1/(1+sτ), where τ = 40 nsec.

5. Connect the cable DUT between the TPA-R-TDR and TPA-R-DI adapters.

6. Measure jitter at TPA-R-DI (procedure same as the source eye measurement).

If data jitter is greater than 0.67 nS (= 0.5*TBIT at 75 MHz), then it implies FAIL.

Calculate the measurement BOX vertical setting as follows:

VC = ( VH+VL)/2 = ±5 mV

Test the eye diagram with sink minimum eye mask. If any of the points violates, then it implies
FAIL.

7. Adjust the DTG swing voltage to (VH, VL) = (3.3 V, 2.9 V) without jitter (clock jitter should remain at
the worst case input condition).
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8. Measure the eye mask on all the TMDS_DATA channels at CTP2.

9. If any measured eyes do not meet the sink minimum eye mask, then it implies FAIL.
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About HTML/MHT Reports
HTML/MHT Reports enhance the TDSHT3 HDMI Compliance Test Software capabilities by simplifying
the process of creating and maintaining results. It automates the process of compiling the test results and
generating the reports. The application generates an MHT file that can be opened in Internet Explorer.

Reports Formats
The generated reports are in .mht format and include the following configured set of information:

Configuration: This section includes the following:

Setup Configuration such as the oscilloscope information and application version.

Device Configuration such as Device Details, Resolution, and Refresh Rate.

Compliance Summary such as the total tests performed and Pass/Fail status.

Test Summary: This section displays the Test Name, Lanes, Specification Range, Measurement
Value, and Results.

Detailed Results: This section includes the following:

Results such as Specification Range, Measurement Value, Tbit, Vswing, Margin, Record length,
Mask Hits, and Results.

Waveform/Plot such as selected plots and/or oscilloscope waveforms.
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Sample Report
A sample report is as follows:
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Software CRU Technology, 239
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